How do I eliminate the scratching sound in this patch.


    Oct 07 2008 | 11:38 pm
    A simple panning patch that is supposed to pan the sound between the left and right channels (0 = Left 1 = Right).
    The problem occurs when changing the float that controls the panning.
    I hear scratching noises when the float is changed and can't think why, can anyone help?
    Thanks

    • Oct 07 2008 | 11:57 pm
      On Oct 7, 2008, at 4:38 PM, Rhys Perkins wrote:
      > The problem occurs when changing the float that controls the panning.
      line~ is your friend here:
      Chris Muir
      cbm@well.com
    • Oct 08 2008 | 12:09 am
      look at the [line] and [line~] objects to see how you can smooth data and signals.
      lh
    • Oct 08 2008 | 12:11 am
      Use the line~ object to eliminate discrete value changes. See MSP tutorial 2.
    • Oct 08 2008 | 9:48 am
      Quote: Chris Muir wrote on Tue, 07 October 2008 17:57
      ----------------------------------------------------
      >
      > On Oct 7, 2008, at 4:38 PM, Rhys Perkins wrote:
      >
      > > The problem occurs when changing the float that controls the panning.
      >
      >
      > line~ is your friend here:
      >
      >
      >
      > Chris Muir
      > cbm@well.com
      > http://www.xfade.com
      >
      >
      >
      >
      >
      >
      >
      ----------------------------------------------------
      Thanks very much for the help guys. I have just migrated to Max 5 and I'm having to re-learn certain procedures.
      Another question...how do I post the Max 5 code as is shown in the quote above? It would seem easier to do it this way rather than attatching .zip files each time!
      Thanks again.
    • Oct 08 2008 | 11:33 am
      Highlight your patch, or only the bits you want to share and then select "copy compressed" from the edit menu and simply paste into the forum.
      lh
    • Oct 08 2008 | 3:42 pm
      Thanks for the info. I'll be making a note of that!