jagged edges on rotated videoplane

    May 07 2012 | 1:45 pm
    Hello. This has been bugging me for a while now... when a videoplane is rotated the edges are aliased, looking quite jagged. Is there a way to antialias these edges to get a smoother looking result? I've poked around the forums and documentation and found nothing to this effect.

    • May 07 2012 | 2:06 pm
      I haven't encountered this but perhaps raising the 'dim x y' of the videoplane can get rid of it?
    • May 07 2012 | 9:12 pm
      I'm not in a position to test this, nor have I tried it before, but I do recall there being an option called interp on the videoplane and many other objects. Interpolation I believe has something to do with aliasing/antialiasing so perhaps that is worth a try.
    • May 08 2012 | 4:22 am
      add the attribute @fsaa 1 to your jit.window.
    • May 08 2012 | 11:52 am
      Thank you so much! Full screen anti-aliasing indeed! That does the trick. And just in time for our video installation at the Mapping Festival. I've been wanting to get more accurate focus on a lot of little screens but needed to do a small bit of rotation which, before fsaa, resulted in big jagged edges.
    • May 08 2012 | 12:32 pm
      ah that kind of jagged edges :)