jit.gl.lua RTT capture fullscreen problem


    Feb 11 2009 | 7:37 pm
    trying out the standard RTT.capture.lua.demo.maxpat demo, when going fullscreen, the screen is blank (the texture is not drawn, no RTT). going back from fullscreen has no effect (still nothing on the screen). restarting the patch, everything works again until i go to fullscreen. anyone else have this problem?
    i tried switching back glreadback to fbo and rtt and ctt with no effect.
    my config is
    jit.gl.lua beta6 mbp 2.1ghz ati 1600x card latest max and mac os

    • Feb 11 2009 | 7:45 pm
      I'll see if I can reproduce. wes
      On Wed, Feb 11, 2009 at 11:37 AM, liubo wrote: > > trying out the standard RTT.capture.lua.demo.maxpat demo, when going fullscreen, the screen is blank (the texture is not drawn, no RTT). > going back from fullscreen has no effect (still nothing on the screen). restarting the patch, everything works again until i go to fullscreen. anyone else have this problem? > > i tried switching back glreadback to fbo and rtt and ctt with no effect. > > my config is > > jit.gl.lua beta6 > mbp 2.1ghz ati 1600x card > latest max and mac os > > >
    • Feb 11 2009 | 8:13 pm
      a few experiments to try to help with symptoms:
      if i were to just resize the window (instead of going fullscreen) i don't loose the texture unless i try to change the window appearance so for example going from a window with border to a borderless window kills it, but just resizing the same window is ok. i imagine it has to do with the steps that go in associating the gl context with a new (or renewed) window
    • Feb 11 2009 | 8:15 pm
      p.s. it's totally the border, because going fullscreen from a borderless window is ok, but from a window with a border kills the rtt texture
    • Feb 13 2009 | 8:33 am
      I can reproduce the problem. It trashing the texture whenever the context is rebuilt from the window changing properties (floating, border, ...). Look for a fix in the near future. wes
      On Wed, Feb 11, 2009 at 12:15 PM, liubo wrote: > > p.s. it's totally the border, because going fullscreen from a borderless window is ok, but from a window with a border kills the rtt texture >
    • Feb 17 2009 | 4:59 am
      I've fixed the problem. It was a silly bug in jit.gl.lua. I've updated the download on my share page with a new build for OSX. wes