jit.phys slow down to stop


    Nov 08 2012 | 11:02 pm
    Hi, does anyone know why with friction 0. and dumping 0. 0. my ball slow down to stop? Thanks

    • Nov 09 2012 | 9:55 pm
      not sure why this happens, but make sure you check out the phys.body.velocity example patch that demonstrates how to query and control the velocity of a rigid-body: Max6/examples/jitter-examples/render/physics/phys.body.velocity.maxpat
      you probably want to make sure you are upgraded to 6.0.8 too.
    • Nov 10 2012 | 9:04 am
      Thank you this solves my problem :)
    • Nov 11 2012 | 12:08 am
      Controlling velocity is a good workaround but maybe it is better fix the problem around restitution I searched in the Bullet forum and i found this thread http://bulletphysics.org/Bullet/phpBB3/viewtopic.php?f=9&t=7922&hilit=restitution the administrator speak about: "enable split impulse, it will prevent the added energy (velocity) from penetrations. Code: m_dynamicsWorld->getSolverInfo().m_splitImpulse = true;"
      Is possible to control split impulse in jitter? Thanks
    • Nov 12 2012 | 5:33 pm
      thanks for digging that up! i will look at implementing this as an option to phys.world.
    • Nov 12 2012 | 6:26 pm
      I'm happy if this can help you I wait for news thanks
    • Mar 01 2013 | 12:50 pm
      Hi, I'm looking for a solution to disable object penetration here a simple example of the problem, I would like the ball doesn't pass through the plane. Thank you for your help
    • Mar 01 2013 | 10:53 pm
      hi you could increase "fixedtimestep" and "maxsubsteps" there is a good explanation here : https://cycling74.com/forums/jit-phys-world-physics-frame-rate-response-maxsubsteps-and-fixedtimestep
    • Mar 01 2013 | 11:09 pm
      Thanks so much