jit.qt.movie, jit.window and images resolution


    Apr 19 2010 | 2:51 pm
    Dear list i have a problem with resolution of images.
    when i load an image (jpg) into jit.qt.movie and display it via jit.window
    the original resolution comes out modified, slightly pixelated, definitely not the original
    I can tell this because if I display the same image with keynote or preview (on a mac) the image looks totally fine
    i used interpolation and some settings of the frame size but this still does not display the right original resolution
    is there something I am missing ? i've been through docs and forum and found that it should be something related to the size difference between jit.qtmovie and jit.window. bur im not sure.
    this happens more likely with images , not with videos (or not that I am aware of).
    any help would greatly appreciated
    thank you in advance
    tom

    • Apr 19 2010 | 7:43 pm
      Hi Tom,
      If you have an image and a very simple patch and an image that exhibits the problem, send it along. OS, computer model and version of Max too.
      -Ben
    • Apr 19 2010 | 11:10 pm
      thanx for answering Ben, here's the patch
    • Apr 19 2010 | 11:11 pm
      this is th eimage I have problems with
    • Apr 19 2010 | 11:14 pm
      As you can see it is a very low quality image. Yet when it is displayed by Keynote, Powerpoint or any preview it has the aspect you can see.
      When I am displaying via jitter, with the above patch , it does this:
    • Apr 19 2010 | 11:16 pm
      my computer is a intel macbook
      Processor Name: Intel Core 2 Duo Processor Speed: 2 GHz Number Of Processors: 1 Total Number Of Cores: 2 L2 Cache: 4 MB Memory: 2 GB Bus Speed: 667 MHz
      with graphic card:
      Chipset Model: GMA 950 Type: Display Bus: Built-In VRAM (Total): 64 MB of Shared System Memory
      Yet, even with the same type of computer, but 2 years younger (so with an updated graphic card) the results are the same.
      thanx a lot in advance if you can help
      tom
    • Apr 19 2010 | 11:42 pm
      unless your jit.window has the same dimensions as your source material, there will be distortion of the image.
      see if this snippet helps at all. it basically utilizes @adapt 1 in jit.qt.movie to keep the dimensions of the source file, and set the @size attribute of the jit.window.
    • Apr 20 2010 | 7:41 am
      it looks it works extraordinarily perfect thank you robtheric thank you all guys
    • Apr 20 2010 | 8:18 am
      observation: I have noticed that using this snippet, it will modify the full screen option I gave for displaying jit.window, and obviously the reason is that the snippet resizes the window's dimensions.
      Basically now I know the reason why of the resolution problems, and how the snippets solves it.
      Yet I noticed that : if I set the jit.window settings to the size of the screen/projector it is going to be displayed , using @adapt 1 on jit.qt.movie, it does the trick without having to resize the jit.window every time we load a movie.
      thankx a lot this list is the best
    • Jun 24 2013 | 7:46 pm
      hi, i am having issues with this as well. I am trying to display an image which is 1366 x 768 but when i full screen, the image ever so slightly distorts. How can i get it not too when on full screen. I have @adapt 1 on the jit.qt.movie object. here is a test patch.
      any help much appreciated!
    • Jun 24 2013 | 9:00 pm
      easiest way is to use opengl, and the jit.gl.cornerpin object with @preserve_aspect 1
    • Jun 24 2013 | 9:33 pm
      Rob Ramirez, thankyou so much.
      i think this will definitely work!
      i was going round in circles with this, and had found a hack way around the issue (which was actually being caused by the @noaccel 1 attribute.
      On my apple machine i didn't need it, but the exhibition was on a windows machine. The attribute was on the patch, and thus causing issues, as i was editing the patch on my own machine. On the windows machine it works fine with the @interp 1 attribute. However your way is much better ad looks much neater with the full border....
      thankyou so much again!