Jitter 1.6.3 release candidate 1 for WIndows XP and OS X Universal Binary


    May 19 2007 | 7:53 pm
    Latest release candidate versions of Jitter 1.6.3 for OS X Universal
    Binary and Windows XP are now available for download at the following
    links. Release notes at bottom.
    As always please let us know of any problems you encounter and
    include example patches, steps to reproduce, and system information
    with your report.
    Windows XP
    OS X Universal Binary
    Thanks,
    Joshua
    Jitter 1.6.3 release candidate 1
    new features:
    - jit.gl.multiples added support for matrices with @dimcount > 2
    - jit.gl.graph new radial mode
    bug fixes:
    - jit.broadcast fix for threading issues
    - jit.dx.grab fix for "write filename 0" crash bug (if frame rate is
    specified as - jit.dx.videoout fix for crash when clicking open without camera
    attached
    - jit.freeframe fix for plug-ins employing in-place processing
    - jit.gl.model fix for materials mapping to incorrect groups
    - jit.gl.multiple fix for leftmost inlet double draw
    - jit.gl.multiple fix for invalid bind target errors with shaders
    - jit.gl.render speed improvement for many disabled jit.gl.* objects
    - jit.gl.shader fix for vertex attribute binding
    - jit.gl.sketch fix for material state bleed through
    - jit.gl.sketch fix for roundedplane command
    - jit.gl.slab speed and resource improvement
    - jit.gl.slab fix for @inputs > 8 crashes
    - jit.gl.texture fix for error messages
    - jit.gl.videoplane fix for changing texture related attributes, so
    that it rebuilds geometry
    - jit.net.send/recv fix for threading issues
    - jit.plume fix for divide by zero crash on intel
    - jit.qt.movie fix for asyncread's missing loop notifications
    - jit.qt.movie fix for getmoviename and getmoviepath's incorrect use
    of windows character encodings
    - jit.qt.movie fix for playhints defaults problem
    - jit.tiffany fix for non-char types

    • May 19 2007 | 9:06 pm
      Installer bug,
      The Universal Binary Installer says: "You cannont install Jitter16 on this
      volume. MaxMSP 4.6 or greater is required...."
      I have max 4.6.2 and have been using the jitter 1.6.3b2 for quite some time.
    • May 19 2007 | 9:10 pm
      On 19 mai 07, at 23:06, Christopher Overstreet wrote:
      > Installer bug,
      >
      > The Universal Binary Installer says: "You cannont install Jitter16
      > on this
      > volume. MaxMSP 4.6 or greater is required...."
      >
      > I have max 4.6.2 and have been using the jitter 1.6.3b2 for quite
      > some time.
      What's the location of your Max folder? Is it /"Applications/MaxMSP
      4.6"?
      ej
    • May 19 2007 | 9:24 pm
      On May 19, 2007, at 2:06 PM, Christopher Overstreet wrote:
      > Installer bug,
      >
      > The Universal Binary Installer says: "You cannont install Jitter16
      > on this
      > volume. MaxMSP 4.6 or greater is required...."
      >
      > I have max 4.6.2 and have been using the jitter 1.6.3b2 for quite
      > some time.
      If you in fact have have Max located in the correct place, as EJ
      mentioned is required, I would suggest you try installing MaxMSP
      4.6.3 (recommended), and let us know if that solves your issues.
      Thank you,
      Joshua
    • May 19 2007 | 9:50 pm
      Installed with no issues here on 10.4.9 Intel with 4.6.3, just FYI.
      > If you in fact have have Max located in the correct place, as EJ
      > mentioned is required, I would suggest you try installing MaxMSP
      > 4.6.3 (recommended), and let us know if that solves your issues.
      >
      > Thank you,
      > Joshua
      v a d e //
      www.vade.info
      abstrakt.vade.info
    • May 19 2007 | 10:05 pm
      Sorry, been offline for awhile. I thought 4.6.2 was most current. It all
      works now.
      On 5/19/07 2:24 PM, "Joshua Kit Clayton" wrote:
      >
      > On May 19, 2007, at 2:06 PM, Christopher Overstreet wrote:
      >
      >> Installer bug,
      >>
      >> The Universal Binary Installer says: "You cannont install Jitter16
      >> on this
      >> volume. MaxMSP 4.6 or greater is required...."
      >>
      >> I have max 4.6.2 and have been using the jitter 1.6.3b2 for quite
      >> some time.
      >
      > If you in fact have have Max located in the correct place, as EJ
      > mentioned is required, I would suggest you try installing MaxMSP
      > 4.6.3 (recommended), and let us know if that solves your issues.
      >
      > Thank you,
      > Joshua
    • May 19 2007 | 10:33 pm
      On May 19, 2007, at 3:05 PM, Christopher Overstreet wrote:
      > Sorry, been offline for awhile. I thought 4.6.2 was most current.
      > It all
      > works now.
      Thanks. In theory, it should install over 4.6.3, but perhaps
      something's going wrong. If anyone hasn't installed 4.6.3 on OS X and
      could verify Christopher's problem ("MaxMSP 4.6 or greater
      required"), I'd appreciate it.
      Thanks,
      Joshua
    • May 22 2007 | 4:53 pm
      i'm running 4.6.2 on OSX 10.4.8 on mbp, and this rc1 installed fine.
      no problems on XP either, running 4.62.
      previous issues with "gl.slab eatin' cpu" seem much better. also, gl.multiple errors are cleared up, as indicated in release notes.
      built some fairly involved standalones on xp and mac yesterday w/ rc1+4.6.2 and nothing really mysterious popped up yet.
      no news is good news :)
      p
    • May 23 2007 | 12:51 am
      i'm having a problem with shaders on a 2nd monitor.
      WinXP SP2
      2GB RAM
      AMD Athlon X2 3800++
      XFX Nvidia 6200LE "supporting 512 MB" (if 1GB system Ram installed)
      nvidia drivers 9.1.4.7
      max 4.63
      jitter 1.63 rc1
      for example, open the shader-helper for cc.brcosa.jxs
      make window floating
      drag to 2nd monitor
      play a movie
      i just get a black screen
      if i drag the window back to the main monitor, it works fine.
      sadly, I can't say if i was having this problem before. I haven't done any 2nd monitor work on this XP for a while, ever since I downgraded to this 6200 from a 6800GS. Even then, I'm not sure I ever tried shaders on a 2nd monitor.
    • May 23 2007 | 1:02 am
      also, i just updated my nVidia drivers to the most recent on their site, which the properties panel calls version 6.14.10.9371
    • May 23 2007 | 9:30 am
      i know this problem,its pre-1.63.
      i have an nvidia 9700 and get the same blank on second monitor,
      solution for me is to switch from dual view to horizontal span and
      specify a [rect 1024 0 2048 768] instead of full screen.
      On 5/22/07, pnyboer wrote:
      >
      > also, i just updated my nVidia drivers to the most recent on their site, which the properties panel calls version 6.14.10.9371
      > --
      > ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
      > The Lifespan
      > 2 oz brandy
      > 1/2 oz orgeat
      > 1/2 oz maraschino
      > 3/4 oz mix of (meyer) lemon and (yellow) grapefruit juice
      > Shake with ice and serve in a Pernod-rinsed cocktail glass
      >
    • May 23 2007 | 10:14 am
      Hello,
      Here is my workaround (Jitter 1.6.3b2) to get shaders working on a
      second monitor in dualview mode. (will upgrade to 1.6.3 after my tour
      :))
      I have changed the 3D parameter settings within the Nvidia Control panel to :
      "many graphic card acceleration" : "one display performance" instead
      of "multi display performance" (I'm not sure about the exact terms in english).
      And select the second monitor as your main windows monitor (within
      something like "display settings").
      It works, exept that ONLY the main windows monitor got the graphic
      acceleration, and you have to move the windows task bar to the
      appropriate place.
      Bertrand
      7600 GT AGP with 6.14.10.9371 Nvidia drivers
      Max 4.6.2
      Jitter 1.6.3b2
      2007/5/23, yair reshef :
      > i know this problem,its pre-1.63.
      > i have an nvidia 9700 and get the same blank on second monitor,
      > solution for me is to switch from dual view to horizontal span and
      > specify a [rect 1024 0 2048 768] instead of full screen.
      >
      >
      > On 5/22/07, pnyboer wrote:
      > >
      > > also, i just updated my nVidia drivers to the most recent on their site, which the properties panel calls version 6.14.10.9371
      > > --
      > > ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
      > > The Lifespan
      > > 2 oz brandy
      > > 1/2 oz orgeat
      > > 1/2 oz maraschino
      > > 3/4 oz mix of (meyer) lemon and (yellow) grapefruit juice
      > > Shake with ice and serve in a Pernod-rinsed cocktail glass
      > >
      >
      --
    • May 23 2007 | 4:09 pm
      ugh! well, i hope C74 can get this working for 1.63! Josh, lemme know if you want any testing help for this issue.
    • May 23 2007 | 4:40 pm
      On May 23, 2007, at 9:09 AM, pnyboer wrote:
      > ugh! well, i hope C74 can get this working for 1.63! Josh, lemme
      > know if you want any testing help for this issue.
      Sorry. Not likely that this will be fixed on our end for 1.6.3. I
      just started what I hoped to be the final build scripts, and this
      should be the last 1.6.X release, with all further Jitter work this
      year going towards the version compatible with Max 5.
      Unfortunately, I have never been able to reproduce this issue on
      either of my NVidia XP machines, which leads me to believe that
      there's something subtle about the driver settings or HW combination,
      or ???. There might be other driver settings you can employ to solve
      this, but I'd be stabbing in the dark speculating on this. Another
      stab in the dark would be to make sure is that the display is set to
      millions of colors.
      Here's another suggestion for diagnostic purposes, if you move the
      window to the other display first, and then start rendering, does it
      work?
      Here's a hack that has worked for some people: make it so that
      there's a hair of the window still on the main display.
      Thanks for your feedback.
      -Joshua
    • May 23 2007 | 4:58 pm
      Seems like it might be a general driver issue, since I found the
      following in my online search, and some similar recommendations for
      other OpenGL based software:
      "Autodesk recommends the use of "Span Mode" for Dual Monitor
      configurations using Nvidia cards."
      http://www.alias.com/eng/support/maya/qualified_hardware/QUAL/
      maya_80_win.html
      To the general list, a few questions:
      1. Anyone else have similar setup to Peter and *not* having issues
      with shaders on a second display? Any monitor/driver settings you
      think might be relevant?
      2. Anyone experiencing this problem on similar HW running Vista?
      Thanks,
      Joshua
    • May 23 2007 | 5:28 pm
      > To the general list, a few questions:
      >
      > 1. Anyone else have similar setup to Peter and *not* having issues
      > with shaders on a second display? Any monitor/driver settings you
      > think might be relevant?
      >
      No, we have the same problems as Peter. Using PC with a 7950 GX2
      graphics card.
      > Here's a hack that has worked for some people: make it so that
      > there's a hair of the window still on the main display.
      This worked for us.
      Best Lucas
    • May 23 2007 | 6:58 pm
      "Here's another suggestion for diagnostic purposes, if you move the
      window to the other display first, and then start rendering, does it
      work?"
      no. i'll give these other things a try and see what happens.
    • May 23 2007 | 8:00 pm
      ok, the "leave a hair on the main monitor" method works (is the "clarence thomas" method? yeah, I know, I'm bad...) without any drastic change in performance, it seems.
      whew!
      p
    • May 24 2007 | 11:24 am
      Joshua Kit Clayton skrev:
      > Here's another suggestion for diagnostic purposes, if you move the
      > window to the other display first, and then start rendering, does it
      > work?
      That didn't work for me, unfortunately - the second the window is moved
      completely on to the second display the rendering stops.
      Andreas.
    • May 24 2007 | 11:44 am
      subzero skrev:
      >> To the general list, a few questions:
      >>
      >> 1. Anyone else have similar setup to Peter and *not* having issues
      >> with shaders on a second display? Any monitor/driver settings you
      >> think might be relevant?
      >>
      >
      > No, we have the same problems as Peter. Using PC with a 7950 GX2
      > graphics card.
      Same problem here, with a 8800 gts card. Funny thing is that it hasn't
      always been a problem. I am not at all sure why, but I had it working
      for a long time on the Jitter beta. Also, th
      >
      >
      >> Here's a hack that has worked for some people: make it so that
      >> there's a hair of the window still on the main display.
      >
      > This worked for us.
      It "sort of" worked for me. Unfortunately this means that I get broken
      frame-grabs when grabbing the openGL window to disk (with Fraps). In
      other words I think I have to try to find a way to fix this, since I use
      Fraps grabs religiously.
      Andreas.
    • Aug 01 2007 | 9:44 am
      "You cannont install Jitter16 on this
      volume. MaxMSP 4.6 or greater is required"
      maxmsp463all.dmg
      jitter163.dmg
      OSX 10.3.9
      Applications/MaxMSP 4.6
    • Aug 01 2007 | 10:05 am
    • Aug 01 2007 | 2:11 pm
      It is!