loading audio from a video into a buffer?


    Jun 04 2010 | 1:31 pm
    Is there a way to load the audio from a video immediately into a buffer? I had a look at spigot but I see no way to access the cached file. I could just separate the audio from the video and load them at the same time but thats a lot of work when you want to experiment just with some files.
    Any ideas / tips on the subject?

    • Jun 04 2010 | 2:07 pm
      just to be clear, what you are asking for is a method for loading the audio track in a QT file into a [buffer~] object? sorry but i'm not aware of any solutions for this, think u might have to go with the separation of audio / video files. but maybe someone else knows...
    • Jun 04 2010 | 2:43 pm
      Yes, loading a QT movie with audio into max and the audio automatically transfered to a buffer. I searched the forum but no clue's how to do this. I read that spigot stores the audio in a cache file but I have no idea how to access this file and if thats possible at all.
    • Jun 04 2010 | 5:24 pm
      try the "import" message to buffer~.
      you will have to possibly first read the movie into qt.movie, query the length, resize the buffer~ based on that length, and then import the movie into the buffer~
    • Jun 04 2010 | 6:58 pm
      Yes, import message works great. Great tip. Thanx a million!!!
    • Feb 11 2014 | 10:48 pm
      Hi there!
      This post is from a while back, but I wanted to ask how you guys worked around reading a movie file in ~buffer. I tried what Rob suggested, loading the file into the qt.movie, querying the length and then resizing the buffer to finally try to read the movie file, but ~buffer just will not let me load any video files! A super short tip or example would be most appreciated!
      Thanks a bunch!
      Julio
    • Feb 12 2014 | 10:21 am
      this should work. ?
    • Feb 12 2014 | 10:57 am
      [buffer~] is one of the victima of c74's recent 'update mania'. Several features broke in Max 6.0 Import the audio portion of a .mov file works again with Max 6.1, no need to query length.
    • Feb 12 2014 | 11:08 pm
      Wow! Thank you both for the quick response! Im going use CTRLZJONES method as it sheds light on a couple of other important importing factors! Thanks for the support!
    • Mar 13 2017 | 6:36 pm
      Hello. I have some patches that I builded some time ago that use to work fine when I needed to load the audio of video file into a [buffer~]. I can't understand why, none of them are working today. In troubleshooting the cause, I have use the simple patch posted above by DAGGY which uses the message " import blading.mov 0 -1 " into a buffer and it does not work. I always get this message ---> buffer~: blading.mov: can't open I have tried copying the " blading.mov " file into the same folder as my patch as well as making sure , in the file preferences ... , that the folder containining these files was effectively in the path's list. Nothing works yet. Has someone has an idea of something else I could try to find the problems? Thanks a lot for your help.
    • Mar 13 2017 | 8:19 pm
      i believe this feature only works in 32 bit mode
    • Mar 13 2017 | 8:29 pm
      I just tried it and it still works (64bit). Maybe you need to restart your computer?! Sometimes I have this strange behaviour in Max that something which normally works suddenly doesn't. A restart always fix it.
    • Mar 14 2017 | 2:31 pm
      Thank you both for your reply. On my side, even when I restart Max, it is not working. If I switch Max to 32bit mode then it works fine.
      Ultimately, my goal with having the [buffer~] load the audio of a video file is to build a video player which use the [groove~] to drive [jit.movie]. It's nice to only have to read the video file and have the import done automatically on the audio side. Is there another way to read a video file in [jit.move] and have a [buffer~] extract and load the audio? Or the only method is to extract the audio from the video file prior to importing them and then import them separately into Max? Thanks again for your help on this.
    • Mar 14 2017 | 9:11 pm
      Hi Doug, Sorry but I made a mistake. in 64bit mode it doesn't work on my system either. I was under the impression I always was running in 64bit mode. Turns out I wasn't :-\
      Maybe you can address this with cycling 74 since it looks like a bug. I see no reason why this could not work in 64bit mode.
      The only workaround I can think of is indeed strip the audio beforehand and import it later.
      Goog luck!
    • Mar 15 2017 | 4:00 pm
      Thanks Danny for your reply confirming it wasn't working on your side either. Just so you know, I wrote to Cycling 74 support to ask about this issue. Here is the answer they gave me, just so you know :
      " I believe that it requires the QT backend, an operation which is not supported in the 64-bit version. The preferred way of working with audio from a movie file now is using the jit.movie~ object. "
      Cheers.