[lua] jit.gl.lua standalone problem


    Aug 12 2009 | 5:06 pm
    i don't seem to be able to make jit.gl.lua standalones applications.
    i tried to export the jit.gl.lua.help as an app and got the following errors:
    jit.submatrix: No such object
    jit.xfade: No such object
    [lua pcall error [string "--internal matrix..."]:5: is not a valid Jitter object name
    ----
    i have mbp 2.1ghz os x 10.5.7
    max 5.0.7
    lua 1.6
    i included the lua script and the lua.framework inside the application.
    any ideas what else i may be missing?
    thanks

    • Aug 12 2009 | 6:18 pm
      hi liubo,
      had the same issue while using jitter objects inside java.
      it could be fixed by putting the listed externals in your:
      myApp.app/Contents/support folder.
      in your case the externals: jit.submatrix.mxo and jit.xfade.mxo
      let us know, if this helps
      will
    • Aug 13 2009 | 1:56 am
      thanks, it almost worked. works ok on lua projects that don't use modules. last thing i need to figure out is where in the package to put the .so files.. i think i tried pretty much every folder and subfolder with no luck.