Max 6.1.7 Released

    Apr 22 2014 | 10:35 pm
    We are happy to share the release of Max 6.1.7 with you!
    There are a number of good bug fixes in this release, as well as a few new features. Most notably, Gen can now export to VDMX ISF ("Interactive Shader Format"), and we have added a new object for performing HTTP requests, maxurl.
    As always, you can download the update here:
    This will install over top of your previous Max 6.1.x installation.
    Enjoy! -Ben
    New Features: • Gen: added subpatcher message to gen subpatchers • Gen: ISF export to gen patchers ( • maxurl: wrapper around libcurl that can perform HTTP requests • poly~: prevents opening window if subpatcher was saved with the window open
    Fixed Bugs: • audio bitwise objects: work the same on all architectures • buffer~: fixed 4th arg to the 'read' message so that a '0' will resize the number of channels • buffer~: fixed behavior of 'replace' to resize the number of channels in addition to the length • buffer~: fixed crashing on 'importreplace' • buffer~: writes raw data • coll: improvements for very long entries • dict: 'contains' works with heirarchy • dict: fix for not wrapping symbols in quotes if the symbol starts with a digit • dict: fixed crashing when setting a value at an invalid array position • dict: fixed memory leak • dict: improved error reporting when using 'set' • dict: improved syntax parsing when quotes are used • dict.pack: added name argument • gen~: fixed gate operator compilation under certain circumstances • enabling @capture no longer affects the color of gl objects • fix for cell operator • jit.phys.body: no longer loses child shapes when enable toggled or shape changed • jit.phys.ghost: fixed crash with colliding ghost objects • jit.phys.multiple: @shape attribute no longer is reset when receiving a new mesh_matrix • jit.release~: fixed possible hang on free • jit.turtle: fixed crash / memory corruption • jsui: new Image from graphics context preserves alpha • kslider: fixed potential memory corruption • live.drop: fixed spurious 'Attempting to convert non UTF-8 characters' warning • live.drop: restores protected sample presets • Max For Live: misc fixes for parameter blob recall and freeing • Max For Live: reading of encrypted samples now works in 64-bit mode • Max For Live: undo gesture improvements • mxj: no longer crashes when it can't find a class • number/flonum: no longer stops scrolling in bpatcher • object defaults: fixed dialog box when saving settings • Packages: Extensions folder can contain mxe64 files • Packages: extras folders now added to the searchpath • patchcord menu: 'delete' no longer removes text in object box • poke~: fixed crash when there is no valid buffer • poke~: fixed sound distortion issues • polybuffer~: numeric sorting for channel in window • pong: fold mode fixes • pong~: properly reads attributes • pow~: no longer sends NaNs or denormals • Projects: app building includes gen~ abstractions • Quicktime: removed API calls from Max kernel • transport: fixed bar count with uneven time signatures • uzi: middle outlet no longer stops firing under certain circumstances • vst~: fixed cpu spike with pitchbend updates • vst~: fixed midi out note velocity • waveform~: fixed redrawing issue with channeloffset

    • Apr 23 2014 | 3:03 am
      Yes--getting velocity correctly from vst~ now. Thank you!
    • Apr 23 2014 | 8:33 am
      Thanks for the update. [maxurl] is not working for me, presumably as I am behind a proxy?
    • Apr 23 2014 | 10:21 am
      Thanks for update.
      Hopelessly waiting for update which could open 32bit object libraries in 64 bit max.
    • Apr 23 2014 | 1:44 pm
      The function object in patches created with Max 6.1.6 does not load in Max 6.1.7. The following error is reported:
      function: function: no such object
      This issue appears in both 32 Bit and 64 Bit versions of Max 6.1.7 on Windows 7. I reported this as a bug. The solution to reinstantiate the function object does not work for me either, because when you have 50+ patches you will not load function in each of them again and resave them.
    • Apr 23 2014 | 3:45 pm
      thanks for the update! mhhh...VDMX ISF export from gen...mhhh..( multiplatform stuff is not in Cycling'74 DNA ;-)...oh poor me win user ). sadly no VDMX for windows.
    • Apr 23 2014 | 4:10 pm
      Hi Ruslan,
      We have not gotten any complaints about this function issue, and I can't repro here.
      It is likely that you have something else in your search path named 'function'. If this isn't the case, could you send a simple patch that shows the problem?
      Thanks, -Ben
    • Apr 23 2014 | 4:49 pm
      @ivnos There are no plans to support opening 32bit externals in 64bit Max. You can however launch a separate 32bit process and communicate via udpsend/receive and similar.
    • Apr 23 2014 | 5:04 pm
      @alfonsosantimonegmailcom there is still jxs and webgl export which may be of use on windows if you build something to wrap the code for your purposes. What type of export would you be looking for specifically in your usage?
    • Apr 23 2014 | 5:12 pm
      Hi Ben, I have function.gendsp file is it an issue? Max 6.1.6 read this files correctly.
    • Apr 23 2014 | 5:34 pm
      Hi Ruslan,
      Yep, that'll do it. Rename that .gendsp file and you should see your function objects return.
    • Apr 24 2014 | 1:03 am
      Hi Luke,
      Sorry, but maxurl currently won't work with a proxy. I did, however, just add support for it today, so please keep a look out for it in the next release.
    • Apr 24 2014 | 3:05 pm
      hey, will install overwrite the Applications/Max6/packages folder ?
    • Apr 24 2014 | 4:03 pm
      Vichug, it shouldn't overwrite anything that you have put there, but it will overwrite any factory content.
    • Apr 24 2014 | 6:44 pm
      Awesome. Allthough i have a problem with dict.iter. If i freeze a device in m4l with dict.iter in it, dict.iter.mxe64 is added to the project as if it would be a 3rd party external. The device will not use dict.iter.mxo on a mac because it tries to use the frozen .mxe64 file as object. It is not a problem of a duplicated file in the search path. Can you reproduce?
    • Apr 24 2014 | 8:48 pm
      Thanks for the update. Although, instead of maxurl I would have named the curl object just curl or even murl. Maxurl seems to me inconsistent; redundant if you will.
      Well, the little things... Cheers.
    • Apr 24 2014 | 11:44 pm
      I love maxurl! Something I always wanted but never asked for :) From now on probably less Java in my projects.
    • Apr 25 2014 | 12:11 pm
      Hi guys! Thanks for the update!
      Hi Luke,
      Sorry, but maxurl currently won’t work with a proxy. I did, however, just add support for it today, so please keep a look out for it in the next release.
      Taking this as an example, I'd love for this section of the site to be updated in a more frequently:
      I understand that there are fixes that need to change many parts of the code, but there are others that only change that particular object. If that is the case, why do we have to wait for the next release 3 or 4 months from now for a bug fix that is already done?
      On a related note, I was disappointed to not see my two bugs reported fixed (regarding the [hover] object and the Max Mac version's behaviour regarding transparency in the background of a window (both documented on a ticket and one of them also here: Maybe in the next update? Or, even better, maybe some of it appears on the "Incremental Object Updates" section? ;-)
      Keep the good work!
    • Apr 26 2014 | 11:58 am
      so, there is still some inconsistency with text editor and very long text lines - i tested the output of maxurl in a dict, and the body line was very long, and shows an inconsistant display behavior at the end of the line that corresponds to a bug i reported here : - it looks as if there is an offset between the currently edited character and the currently read character, which would be like of 1 character for each chunk of 1024 characters or so
    • Apr 26 2014 | 12:06 pm
      but maxurl is a beauty indeed !
    • May 01 2014 | 1:18 am
      sending continuous data changes to a vst parameter still causes pops, clicks and glitches in playback. it has been like this since 6.1.2 if i am correct. here is a patch demonstrating what is happening (and forgive my aleatoric squarewave generators!) running an ADK 1Q SB, Windows 7, Intel i7 Quad-Core Sandy Bridge @ 2.4ghz, 8 gigs of ram.
    • May 01 2014 | 7:40 pm
      I am having some problems with the buffer~ for example, when I replace with an audio file it will not read in the waveform. The reference window reads: buffer~ cannot open parser for this file. Has anyone encountered problems with this? I had originally created the patch on a mac computer at school, which worked fine at the time. I'm running the newest demo version of Max 6.1.7 with windows 8 on my home workstation. Appreciate the help!
    • Jun 12 2014 | 9:26 am
      The resampling issue in groove~ is still not fixed, nearly three years is passed and this really needs a fix!
      Issue is reported here:
      Max is really an invaluable tool for me, but this is now becoming quite frustrating. Any news on this Cycling74?
    • Jun 12 2014 | 11:21 am
      @WHATISAPIA could it be that you are trying to open aiff files from LivePacks or library? they're using a custom format that can't be read by buffer~ (or any other application than Live)
      @GRADIENT I recently discovered this, too. "Resample 1" degrades the sound instead of sounding better. Adds noise and even switching to mono for stereo sounds. absolutely broken. (win 7)
    • Jul 03 2014 | 7:00 am
      VST~ dont update parameter values.
    • Jul 13 2014 | 7:39 pm
      Still no fix on groove~ interpolation? Really?
      That would really piss me off if Max could stop crashing for 5 minutes. Unusable on Windows 7 64. Two different machines.
    • Jul 25 2014 | 2:44 pm
      I'm new here. I want to know if the latest version will work well in windows 8? I seen in some posts that they are encountering problem in window7.
    • Oct 18 2014 | 1:49 pm
      Max contains a very large suite of objects. There are problems with various specific ones, but there is usually an alternative that does work.
    • Mar 10 2015 | 3:50 pm
      this old thread keeps showing up at the frontpage occasionnally for no apparent reason. It's like a ghost thread... spooky...
    • Jun 26 2015 | 7:59 pm
      funny i have just seen that too , second ago .