midi out/in maxmsp


    Feb 09 2009 | 4:16 am
    I am somewhat of a newb so bare with me...
    So in my Midi Setup I have only:
    output (on) Microsoft Synthesizer
    output (on) Microsoft GS Wavetable Synth
    input (on) EDIROL FA-101
    output (on) EDIROL FA-101
    I do not have the 'to MaxMSP 1' or the 'from MaxMSP 1' (1 or 2). I do not know why, but I methinks I need it cuz I cannot get Ableton to read the midi I am sending out.
    In a patch I am sending a bunch of noteout, ctlout, and bendout but alas I cannot get ArKaos VJ MIDI or Ableton to read it (its from a homemade device that will be used to control audio and video effects...). In a friends mac I get from MaxMSP straight in the inputs in Ableton... but not me.
    Can somebody answer this dilemma

    • Jul 15 2009 | 3:21 pm
      I believe you need to use the IAC within mac os x as the transfer mode. You set it up by going to utilities, audio/midi setup, then open the midi devices tab and double click on IAC Driver. You set up a bus and then use that. In MAX set midi output as IAC Bus 1 then in Ableton input as IAC bus 1. However I am currently having a problem...
      I can send midi from Ableton to max using ctlin but when I try to use ctlout ableton does not seem to see any incoming midi.
      any ideas?
    • Apr 13 2011 | 5:02 am
      I'm having a similar problem trying to output MIDI into Abysnth. The only way I can get it to work is through the keymidi keyboard, and when I play the keymidi with miditester open nothing is recognizing any midi signals in the miditester. I tried reversing the outputs and inputs to see if miditester would recognize the absynth midikeyboard but it did not either...