MXJ Carnivore class error

    Dec 19 2009 | 4:39 pm
    Playing around with the Carnivore max example ( and its MXJ classes which I installed as per the instructions and I'm suddenly getting the following error:
    Jitter 1.6.2 installed MXJ System CLASSPATH: /Users/garrett/Desktop/waterfall/Carnivore/example_clients/Max/max.jar MXJClassloader CLASSPATH: /Users/garrett/Desktop/waterfall/Carnivore/example_clients/classes/ (mxj classloader) dynamic classpath entry /Users/garrett/Desktop/waterfall/Carnivore/example_clients/classes/ does not exist. • error: java.lang.NoClassDefFoundError: com/cycling74/jitter/JitterObject • error: Could not load class 'com/cycling74/jitter/JitterObject' • error: could not find jitter.jar
    It looks as if max is linking out to copies of the classes on my desktop and not the ones installed in the Cycling 74' folder. I've had a look at the but I can't find any reference to anything in the error, where does this get configured from? How do I fix it?
    I'm using Max/MSp 4.6.3 on OSX 10.5.7 intel. Thanks in advance.

    • Dec 19 2009 | 6:45 pm
      I've managed to reproduce the exact same error on another machine (this time PPC) and fixed it but the issue still persists on the intel machine. By deleting all the carnivore classes, installed and on the desktop, and launching max again the error disappeared. I then quit and installed the classes again, no errors and they work. This does not seem to work on the intel machine. Anyone have any ideas?