New to Max/MSP/Jitter...weird Powerbook problem


    Dec 29 2005 | 7:58 am
    Hello I just purchased and authorized Max/MSP/Jitter and I'm having a
    strange thing happening with my G4 867 titanium Powerbook
    when Max/MSP is running. There is a steady, high, sawtooth-like pitch
    (a "B" two octaves above middle "C" in fact)
    that comes from under the QWERTY keyboard. It seems loudest under the
    "L", "O" and "P" keys on the right.
    It does this only when Max is open even if there is no patch loaded and
    stops the instant that I quit Max.
    The sound happens constantly whether or not there are other open
    programs and whether or not Max is the forward program.
    The sound will stop briefly when opening other programs or when
    switching between other open programs.
    I have run Reaktor, Supercollider and Pro Tools among other audio
    programs on this machine without
    anything like this happening. This also happens regardless of wether
    the audio is muted or not; or wether or not there
    is a mini-plug plugged in the headphone jack which is how I run audio
    to a mixer most of the time.
    Interestingly though, the sound can be heard through the headphone jack
    when the mini-plug is inserted only about halfway in the
    jack. I don't know what it is (some weird software induced ground
    loop? Max/MSP hates the kind of RAM I have?), but it's pretty darn
    annoying.
    Any help or suggestions would be greatly appreciated.
    Thank you very much.
    -B

    • Dec 29 2005 | 9:48 am
      On around Dec 29, 2005, at 8:58, Briggan Krauss said something like:
      > Hello I just purchased and authorized Max/MSP/Jitter and I'm having a
      > strange thing happening with my G4 867 titanium Powerbook
      There were several threads about this when the Titania first came out.
      I never owned one so I never had the problem. Suggest you try Googling
      the list archive, something like
      titanium buzz site:synthesisters.com
      or
      tibook pitch site:synthesisters.com
      or variations on the above (you can also build combinations with the OR
      keyword in Google).
      I seem to recall this was eventually traced to some obscure hardware
      peculiarity, and is not consistent across all models.
      Hope this helps,
      Peter
      >
      -------------- http://www.bek.no/~pcastine/Litter/ --------------
      Peter Castine | ^
      | Litter Power & Litter Bundle for Jitter
      pcastine@gmx.net |
      pcastine@bek.no | realiTV : http://www.bek.no/~pcastine/Press/
      4-15@kagi.com |
      | http://www.radio-copernicus.de | +- Overnight
      | Sensation
    • Dec 29 2005 | 10:11 am
      hi
      yes, i had it on a titanium, and have it on a 1.5 G4 Pbook
      it's not that loud, but it's there....
      well, at least you know than MAX is running!!!
      best
      kasper
      --
      Kasper T. Toeplitz
      noise, composition, bass, computer
    • Dec 29 2005 | 11:24 pm
      On around Dec 29, 2005, at 8:58, Briggan Krauss said something like:
      > Hello I just purchased and authorized Max/MSP/Jitter and I'm having
      > a strange thing happening with my G4 867 titanium Powerbook
      >
      You can use this application to tune the noise to whatever pitch you
      like:
      Hope that helps. :-)
      mzed
      || michael f. zbyszynski, ph.d. -- music composition research
      || mzed@cnmat.berkeley.edu -- +1.510.643.9990x314
    • Dec 30 2005 | 7:11 am
      On Dec 29, 2005, at 2:58 AM, Briggan Krauss wrote:
      > Hello I just purchased and authorized Max/MSP/Jitter and I'm having
      > a strange thing happening with my G4 867 titanium Powerbook
      > when Max/MSP is running. There is a steady, high, sawtooth-like
      > pitch (a "B" two octaves above middle "C" in fact)
      > that comes from under the QWERTY keyboard. It seems loudest under
      > the "L", "O" and "P" keys on the right.
      > It does this only when Max is open even if there is no patch loaded
      > and stops the instant that I quit Max.
      The sound you're experiencing is perfectly normal for some Apple
      laptops. This is due to a hardware oscillation created by the Max
      scheduler. Other things can cause this as well (Quicktime movie
      previews in the Finder when in column view do it for me).
      One solution is to adjust the Schedule Event Interval to a slower
      setting in "Options -> Performance Options...". A faster setting
      gives a higher pitch, and a slower setting gives a lower one. If it
      is slower than 15ms it is close to inaudible. This may have an
      adverse effect on your patches though, so I'd not suggest it.
      The other solution is to change your system performance in Energy
      Saver from "Highest" (which given your symptoms, I'm sure it is set
      to) to "Automatic".
      Hope it helps.
      - John
    • Dec 30 2005 | 7:15 am
      The SystemLoad application icon makes me crack up. looney tunes and
      all that.
      ohh..boy is it late.
      v a d e //
      www.vade.info
      abstrakt.vade.info
    • Dec 30 2005 | 12:28 pm
      Normal but very annoying.
      Another way to turn off the buzz is to install Apple's "Processor"
      preference panel (it's in the developer toolkit, but I think there is a
      smaller download available which includes it too) and turn off the
      "nap" setting. The drawback is that the temperature of your processor
      will increase...
      p
    • Jan 01 2006 | 1:21 am
      Thank you all for the advice on the weird sound issue.
      Changing the Schedule Event Interval does change the pitch of the sound
      but
      I don't want to mess with this until I know more about what I'm doing
      with Max.
      Changing the Energy Saver preferences didn't seem to have any effect
      though.
      I tried looking all over the Apple web site for Developer Toolkit and
      Processor
      Preference Panel but only found oblique references which seemed to
      indicate that
      it may only be available to OS 10.4 Tiger (true?). I'm on OS 10.3.9...
      Anyway, the important thing I've learned is that it's a harmless sound
      (though annoying)
      and doesn't indicate some kind of hardware malfunction so for now I'll
      just live with it.
      Thanks again for your help.
      -B
      Briggan Krauss
    • Jan 01 2006 | 5:25 am
      On Dec 31, 2005, at 8:21 PM, Briggan Krauss wrote:
      > Thank you all for the advice on the weird sound issue.
      > Changing the Schedule Event Interval does change the pitch of the
      > sound but
      > I don't want to mess with this until I know more about what I'm
      > doing with Max.
      > Changing the Energy Saver preferences didn't seem to have any
      > effect though.
      > I tried looking all over the Apple web site for Developer Toolkit
      > and Processor
      > Preference Panel but only found oblique references which seemed to
      > indicate that
      > it may only be available to OS 10.4 Tiger (true?). I'm on OS
      > 10.3.9...
      > Anyway, the important thing I've learned is that it's a harmless
      > sound (though annoying)
      > and doesn't indicate some kind of hardware malfunction so for now
      > I'll just live with it.
      > Thanks again for your help.
      You may also want to try installing the CHUD tools and disabling
      processor napping. This also works for me, and allows me to run on
      the highest performance setting and without any other tweaks. It can
      make your fans kick on sooner though.
      In short... deal with it. :-) You'll have a new Intellibook soon
      anyway, right?
      - John
    • Jan 01 2006 | 2:28 pm
      On around Jan 1, 2006, at 2:21, Briggan Krauss said something like:
      > I tried looking all over the Apple web site for Developer Toolkit and
      > Processor
      > Preference Panel but only found oblique references which seemed to
      > indicate that
      > it may only be available to OS 10.4 Tiger (true?).
      The Toolkit has been available yonks (there have been developer tools
      for every Mac since 1984), but it may be difficult (even bordering on
      impossible) to find past versions. FWIW, I have the Processor Pref
      panel installed on my 10.3.9 machine.
      FWIW -- P.
      -------------- http://www.bek.no/~pcastine/Litter/ --------------
      Peter Castine | ^
      | Litter Power & Litter Bundle for Jitter
      pcastine@gmx.net |
      pcastine@bek.no | realiTV : http://www.bek.no/~pcastine/Press/
      4-15@kagi.com |
      | http://www.radio-copernicus.de | +- Overnight
      | Sensation
    • Jan 01 2006 | 3:45 pm
      On Jan 1, 2006, at 9:28 AM, Peter Castine wrote:
      > On around Jan 1, 2006, at 2:21, Briggan Krauss said something like:
      >> I tried looking all over the Apple web site for Developer Toolkit
      >> and Processor
      >> Preference Panel but only found oblique references which seemed to
      >> indicate that
      >> it may only be available to OS 10.4 Tiger (true?).
      >
      > The Toolkit has been available yonks (there have been developer
      > tools for every Mac since 1984), but it may be difficult (even
      > bordering on impossible) to find past versions. FWIW, I have the
      > Processor Pref panel installed on my 10.3.9 machine.
      Definitely included in Panther -- Not sure about Jaguar. It shows up
      when you install the CHUD tools off the Panther developer CD, or off
      the Tiger DVD. For what it is worth, Apple recommends against
      disabling napping using this anyway for any length of time.
      - John
    • Jan 09 2006 | 6:00 am
      I know I'm a bit late on this thread, but here is a patch that was
      posted on the list a while back that lets you alter the sound of the
      buzz. The last setting in the umenu makes the buzz pretty much totally
      gone on my 1ghz powerbook.
      Unfortunately I can't remember the original author of the patch.