[ot] filtering this list


    Feb 28 2006 | 4:38 pm
    I have tried to filter both the max-msp and jitter list emails in
    Apple Mail but for some reason none of the fields I use seem to route
    my email to the correct folder...has anyone else experienced this and
    if so were you able to fix it?
    OS X 10.4.5
    Apple Mail 2.0.5
    sorry for the [ot] post!
    KIM

    • Feb 28 2006 | 4:53 pm
      funny : you're one of the few messages i got in my unfiltered folder !
      Yes, on win with thunderbird, i sometimes have problems too...
      f.e
    • Feb 28 2006 | 4:55 pm
      I use the Rule thing and send all message that are send to:
      maxmsp@cycling74.com to a Max/Msp folder,
      and all message that contain jitter@cycling74.com to a Jitter folder.
      Is it what you tried also?
      Benjamin
      ------------------------------------------------------------ -----
      RECYCLISM - BNJMN GAULON
      art : http://recyclism.com
      recycling : http://digitalrecycling.com
      collective : http://deponk.com
      ------------------------------------------------------------ -----
    • Feb 28 2006 | 4:55 pm
      ... it appears that you send to the old adress which is
      max-msp@cycling74. The new is maxmsp@cycling74... It may have something
      to do with that.
    • Feb 28 2006 | 4:56 pm
      Hi Kim,
      you could use something like
      if
      perform
      move message etc.
      Works for me, MacOSX39
      Note the list is now called maxmsp, not max-msp
      p
      _____________________________
      Patrick Delges
      Centre de Recherches et de Formation Musicales de Wallonie asbl
    • Feb 28 2006 | 4:59 pm
      hey, I've tried hard to set up a working filtering of max/msp list
      emails in my gmail webmail account but it works in a very unreliable
      way...I thought it was a gmail problem, despite it works and it is
      reliable for other lists emails.
      Your post makes me think that probably there is some other issue behind it...
      No solutions, but I'm very curious..
      d.
    • Feb 28 2006 | 6:17 pm
      try filtering with the "Reply-To:" field.
      it's more reliable.
      best,
      jonathan
    • Feb 28 2006 | 6:36 pm
      I thought of that too...it doesn't work...
    • Feb 28 2006 | 6:48 pm
      I'm using gmail and I can say that it does in fact work. Here's my filter rule:
      Matches: to:(Max/MSP )
      Do this: Apply label "Max/MSP"
      wes
    • Feb 28 2006 | 7:57 pm
      Kim,
      Are you sure you're filtering on the "To: maxmsp@cycling74.com" and not "To: max-msp@cycling74.com"? While I do all my filtering with server-side scripts employing the Mail::Audit perl module, the only change I had to make was to change max-msp to maxmsp.
      Another thing that people sometimes forget is to filter on the CC: field as well.
      w
    • Feb 28 2006 | 8:14 pm
      Indeed - I only began getting leaks into my Inbox (they are filtered
      same as everyone else here, by fastmail's IMAP server) when the new
      system recently came into being. Now I get a couplehalf-dozen
      messages per day that "don't make it" and wind up in my Inbox instead of
      following the rules.
      Though sometimes these days that's the only way things come to my
      attention.. (such as this discussion).
    • Feb 28 2006 | 8:33 pm
      i had the same problem (mail, 10.3.9) but now filter on subject: contains maxmsp, a bit rough but works perfectly.
      >I have tried to filter both the max-msp and jitter list >emails in
      >Apple Mail but
    • Feb 28 2006 | 9:03 pm
      On Feb 28, 2006, at 11:57 AM, wallace winfrey wrote:
      > Are you sure you're filtering on the "To: maxmsp@cycling74.com" and
      > not "To: max-msp@cycling74.com"? While I do all my filtering with
      > server-side scripts employing the Mail::Audit perl module, the only
      > change I had to make was to change max-msp to maxmsp.
      yup...
      jitter@cycling74.com
      I'm grabbing them directly from the To: field...
      >
      > Another thing that people sometimes forget is to filter on the CC:
      > field as well.
      I've tried creating a Reply To: and using it but it also doesn't work
    • Feb 28 2006 | 9:10 pm
      Eudora has a nice option to filter on an e-mail address for "Any
      Recipient" - that's what I use, and it works beautifully.
      Dan
      --
      Dan Nigrin
      Defective Records
      202 Hack / PC-1600 User / VSTi Host / OMS Convert / Jack OS X
      http://www.defectiverecords.com
    • Feb 28 2006 | 11:59 pm
      It's interesting that filtering on the To: field would suddenly not work. The only thing that's different is the spelling of the listname, and I've seen no difference in my own client's filtering behavior that would suggest that something else is amiss.
      The only other constant in the messages I can point to is the presence of "[maxmsp]" or "[jitter]" in the Subject: line. These will always be in there.
      While I hate to make server changes to get around client flaws, if it's a big enough problem for folks, I suppose I could add a custom header to mailing list posts, although I suppose there's no guarantee that will work either.
      I'll do some testing in the next few days with Apple Mail and Gmail and see what I can find out. Thanks for your patience in the meantime.
      cheers
      w
    • Mar 01 2006 | 2:23 am
      On Feb 28, 2006, at 8:56 AM, Patrick Delges wrote:
      > you could use something like
      > if
      > perform
      > move message etc.
      I tried this and it doesn't work...
      >
      > Works for me, MacOSX39
      are you using Apple Mail?
      >
      > Note the list is now called maxmsp, not max-msp
      I know and have made this modification in my rules
    • Mar 01 2006 | 2:24 am
      Mail.app has "Any Recipient" as well.
      My MAX_MSP rule in mail looks like:
      if [any] of the following conditions are met:
      Subject Contains [max-msp]
      Subject Contains [maxmsp]
      Any Recipient Contains max-msp@cycling.com
      Any Recipient Contains maxmsp@cycling.com
      Perform the following actions:
      Move Message to mailbox: Max-MSP
      and I've never had any messages slip through.
      _Mark
    • Mar 01 2006 | 2:26 am
    • Mar 01 2006 | 2:36 am
      I'll try this and see if it works...thanks for the tip!
      On Feb 28, 2006, at 6:24 PM, Mark Pauley wrote:
      > Mail.app has "Any Recipient" as well.
    • Mar 01 2006 | 5:28 am
      On Feb 28, 2006, at 9:26 PM, Kim Cascone wrote:
      > there is something about Apple Mail 2.0.5 that doesn't like the
      > maxmsp jitter headers! :(
      > all my other lists filter perfectly and I don't have a problem
      hi kim
      i'm using mail 2.05 on my alumbook 1.67, now os x 10.4.5. my
      scenario for filtering
      is based on To: max-msp To: maxmsp To: cycling74
      i get everything, no spill overs.
      cheers
      bruce
      bruce tovsky
      www.skeletonhome.com
      "Flying is learning how to throw yourself at the ground and miss."
      Douglas Adams
    • Mar 01 2006 | 6:56 am
      hi kim,
      i'm not sure what caused it, but a while ago my max/msp list mails
      started slipping through my Apple Mail filter.
      (i think I added the jitter list to be filtered as well, or
      something.) Anyways, I couldn't figure out why, when things were
      seemingly set correctly,
      as you have done, why messages kept slipping through.
      In the end, what fixed it for me was to delete all of the filters,
      save those changes and then go back in and define them afresh.
      This may have been something unique to my scenario, but it worked for
      me. It may be worth a shot.
      (simply retyping/redefining the filters did not work. I had to start
      fresh.)
      Best,
      Corey
    • Mar 01 2006 | 11:01 am
      Fwiw, I have the same problem with Entourage (Mac), and it has always been
      this way, even with the old (hyphenated) list; about 80% of the list mails
      filter correctly, but I have never been able to see what's different about
      the other 20%,
      Cheers
      Roger
    • Mar 01 2006 | 3:25 pm
      On Feb 28, 2006, at 6:24 PM, Mark Pauley wrote:
      > Mail.app has "Any Recipient" as well.
      FYI: this does not filter the maxmsp nor the jitter lists in my Apple
      Mail client
    • Mar 01 2006 | 3:27 pm
      On Feb 28, 2006, at 10:57 PM, Corey Fuller wrote:
      > In the end, what fixed it for me was to delete all of the filters,
      > save those changes and then go back in and define them afresh.
      > This may have been something unique to my scenario, but it worked
      > for me. It may be worth a shot.
      > (simply retyping/redefining the filters did not work. I had to
      > start fresh.)
      this was one of the the first things I tried...I have done this ONLY
      with the maxmsp and jitter filters...I have too many filters created
      in Mail to delete and retype them all in by hand...
    • Mar 01 2006 | 3:30 pm
      On Mar 1, 2006, at 3:01 AM, Roger Carruthers wrote:
      > Fwiw, I have the same problem with Entourage (Mac), and it has
      > always been
      > this way, even with the old (hyphenated) list;
      yes I had the same experience with my older Mail client as well as
      the older max-msp and jitter lists...I recently upgraded to OS X
      10.4.x which I thought would install a new version of Mail that might
      cure this - but it didn't make any difference
    • Mar 01 2006 | 6:22 pm
      Check your mail rules. I'll bet you either have a conflict in there,
      or it's not enabled or the destination folder doesn't exist or
      something. You don't have maybe two machines that are running at the
      same time do you? You could get into a race condition like that,
      where the one with the wrong rules is grabbing and sorting the mail
      first.
      That rule has been working for me since 10.3.5
      _Mark
    • Mar 01 2006 | 9:57 pm
      I'm filtering on subject. If subject contains [maxmsp] etc.... Maybe
      you would get that working?
      Best,
      Trond
    • Mar 02 2006 | 4:43 am
      On Feb 28, 2006, at 11:38 AM, Kim Cascone wrote:
      > I have tried to filter both the max-msp and jitter list emails in
      > Apple Mail but for some reason none of the fields I use seem to
      > route my email to the correct folder...has anyone else experienced
      > this and if so were you able to fix it?
      FWIW, not a single message from either list gets past my filters;
      They all end up in the right spot. I'm using Mail.app 2.0.5 in
      10.4.4. Obviously this is not a solution, but it is an indicator that
      things *should* be able to work fine with Mail. Try killing the
      filters and folders and starting over.
      If it makes a difference, I use "any recipient" rather than "to",
      otherwise I miss things like people cc'ing the list (which I insist
      is insane behaviour, but there you are).
      - John
    • Mar 02 2006 | 12:18 pm
      try this folks:
      List-Id: General discussion and questions about Max/MSP
      use that header, its for identifying mailing lists.
      all list mails have this header.
      On 02 Mar 2006, at 15.43, John Nowak wrote:
      > If it makes a difference, I use "any recipient" rather than "to",
      > otherwise
    • Mar 02 2006 | 1:07 pm
      On Mar 2, 2006, at 7:18 AM, Casey Rice wrote:
      > try this folks:
      >
      > List-Id: General discussion and questions about Max/MSP
      >
      >
      > use that header, its for identifying mailing lists.
      >
      > all list mails have this header.
      Unfortunately Mail.app does not offer an option to do such a thing,
      so you're stuck doing it the clunky way.
      - John
    • Mar 02 2006 | 2:56 pm
      now way man!! john, this List-ID *does* work in Apple Mail.app!!! i'd
      never seen it before but...
      1.) goto rules
      2.) edit (or create) your max-msp list rule
      3.) form the condition type, look at the very bottom of the condition
      list for "Edit Header List..." and select it.
      4.) Click the "+" button and add "List-Id" to the list. Click OK.
      5.) Back in the condition list, you now have List-Id !!!
      6.) Make a rule: List-Id - Contains - General discussion and
      questions about Max/MSP
      casey, this is just wonderful! :)
      thank you!!
      -jonathan
    • Mar 03 2006 | 12:07 am
      yes, it does. try 'edit header list...'
      i use it to filter with mail.app
      On 03 Mar 2006, at 00.07, John Nowak wrote:
      > Unfortunately Mail.app does not offer an option to do such a thing, so
      > you're stuck doing it the clunky way.