pattr issue at initialisation


    Feb 05 2008 | 9:10 am
    hi list,
    it seems that pattr keeps in memory the last value received before closing of a patch and recalling it at opening of this patch, without being receiving any loadbang , why is that ?
    is there an argument/message that prevents this ?
    in the posted patch , the pattred yellow number box will output its value no matter what at the loading of a the patch .
    i could think of a workaround , but i am curious about the behaviour;
    expected behaviour : no values are stored in the pattr objects at theloading of a patch, unless they are asked for it before closing the same patch .
    some little clarification on Super Tuesday would be welcome :)
    what does this line mean : " #X prestore 1 0 5000;" ?
    is it related to my issue ?

    • Feb 05 2008 | 9:32 am
    • Feb 05 2008 | 9:33 am
      This is one of pattr's most useful features! You can, however, disable it with:
      @autorestore 0
      jb
    • Feb 05 2008 | 9:46 am
      it is sure very usefull but i did not the feature in this specific case , anyway thanks for pointing the autorestore attribute
      ( should have checked the reference manual first, sorry for the bandwith ...)
      Quote: Jeremy Bernstein wrote on Tue, 05 February 2008 10:33
      ----------------------------------------------------
      > This is one of pattr's most useful features! You can, however, disable it with:
      >
      > @autorestore 0
      >
      > jb
      ----------------------------------------------------