problem loadin jsui in "standalone externals"


    Dec 15 2006 | 9:30 am
    salut,
    i experienced some bizarre issue with jsui objects recently: I have a fairly complex main patch which I managed to compile as a standalone (hurra!), and which I load with a "launcher patch" where I set first set some search paths for sound and image bank, then loading the main patch with pcontrol.
    The simple_dial and other jsui components load fine in the main patch. Now, I have synthesizer modules to be loaded via scripting. (these are .mxt which I'd like to compile as .mxf but cannot for the sake of passing # arguments when instantiating... see previous posts)
    These module patches also contain some jsui components, but
    *these one do not load.* (thats my problem here...:) )
    Could it be linked to this error message i have in the max window when loading the main application patch? : (mxj) Unable to resolve path of max.jar! mxj is rendered powerless. *error: Unable to create JVM
    Also I have this message when loading the (.mxt) patcher module: *error js: no function brgb (which seems to be outputed by the jsui objects)
    For information, I run max 4.6.2 and jitter 1.6.2. Same error was observed on both Mac PowerBook PPC and PC with winXP.
    I don't know if I make it clear, and guess my mail is difficult to understand, but if anyone has an idea about what I am talking about... please help :)
    vincent

    • Dec 15 2006 | 11:07 am
      Hi Vincent,
      You need to include a bunch of Java stuff in your standalone app (actually a folder). You can probably search the archives for more information. I got some help from C74 on how to do this, but gave up on the idea of building a standalone app. Just too much hassle.
      HTH,
      Z
      Zip Boterbloem Media Mechanics Zwaluwstraat 54 2025 VR Haarlem The Netherlands +31627014758 zip@knoware.nl
      Op 15-dec-2006, om 10:30 heeft vg. het volgende geschreven:
      > salut, > > i experienced some bizarre issue with jsui objects recently: > I have a fairly complex main patch which I managed to compile > as a standalone (hurra!), and which I load with a "launcher patch" > where I set first set some search paths for sound and image bank, > then loading the main patch with pcontrol. > > The simple_dial and other jsui components load fine in the main patch. > Now, I have synthesizer modules to be loaded via scripting. > (these are .mxt which I'd like to compile as .mxf but cannot for > the sake > of passing # arguments when instantiating... see previous posts) > > These module patches also contain some jsui components, but > > *these one do not load.* (thats my problem here...:) ) > > Could it be linked to this error message i have in the max window > when loading the main application patch? : > (mxj) Unable to resolve path of max.jar! mxj is rendered powerless. > *error: Unable to create JVM > > Also I have this message when loading the (.mxt) patcher module: > *error js: no function brgb > (which seems to be outputed by the jsui objects) > > For information, I run max 4.6.2 and jitter 1.6.2. > Same error was observed on both Mac PowerBook PPC and PC with winXP. > > I don't know if I make it clear, and guess my mail is difficult to > understand, > but if anyone has an idea about what I am talking about... please > help :) > > vincent >
    • Dec 18 2006 | 10:14 am
    • Apr 22 2007 | 9:04 pm
      I recently experienced the same kind of problem. I'm buiding an application wich never works on my PPC (10.3.9) but for the las months, for the recedent releases it worked fine on my intel macbook. Suddenly, the application won't work and the max window prints : error : unable to create JVM (mxj) Unable to find max.jar!mxj is rendered powerless in its absence. I did'nt change anything. The only thing I did was probably to try working out some javascripts tutorials. Roland
    • Apr 22 2007 | 10:42 pm
      On 22 avr. 07, at 23:04, cahen wrote:
      > I recently experienced the same kind of problem. > I'm buiding an application wich never works on my PPC (10.3.9) but > for the las months, for the recedent releases it worked fine on my > intel macbook. > Suddenly, the application won't work and the max window prints : > error : unable to create JVM > (mxj) Unable to find max.jar!mxj is rendered powerless in its absence. > I did'nt change anything. The only thing I did was probably to try > working out some javascripts tutorials.
      Hi Roland,
      JVM concerns java externals not javascript's one. Do you use any java external (mxj *) in your standalone?
      Cheers, ej
    • Apr 23 2007 | 8:14 am
      I dont use any MXJ externals in the patch as far as I know. If this can help, at max startup I get MXJ System CLASSPATH : jitter.jar jode-1.1.2-preembeded.jar max.jar ftmjava.jar & java/classes/
      Thanks a lot Roland
    • Apr 23 2007 | 8:59 am
      On 23 avr. 07, at 10:14, cahen wrote:
      > I dont use any MXJ externals in the patch as far as I know. > If this can help, at max startup I get MXJ System CLASSPATH : > jitter.jar > jode-1.1.2-preembeded.jar > max.jar > ftmjava.jar > & > java/classes/
      Do you use FTM in your standalone? FTM editors use java, so that would explain.
      ej