Problem of FFT object of MacOS10.4.6 and MaxMSP4.5.7.


    Apr 04 2006 | 11:30 am
    I updated it to MacOS10.4.6 today. Afterwards, the FFT object and "/~" object of MaxMSP4.5.7 cannot be used. The error message and the object are the following.
    C74 Objects
    "fftin~"
    ? error: can't fragload fftin~ (missing <>), err -2804
    "fftout~" ? error: can't fragload fftout~ (missing <>), err -2804
    "fft~"
    ? error: can't fragload fft~ (missing <>), err -2804
    "gizmo~"
    ? error: can't fragload gizmo~ (missing <>), err -2804
    "ifft~"
    ? error: can't fragload ifft~ (missing <>), err -2804
    "/~"
    ? error: can't fragload /~ (missing <>), err -2804
    FFTease Objects
    "burrow~"
    ? error: can't fragload burrow~ (missing <>), err -2804
    "dentist~"
    ? error: can't fragload dentist~ (missing <>), err -2804
    "disarray~"
    ? error: can't fragload disarray~ (missing <>), err -2804
    "drown~"
    ? error: can't fragload drown~ (missing <>), err -2804
    "ether~"
    ? error: can't fragload ether~ (missing <>), err -2804
    "morphine~"
    ? error: can't fragload morphine~ (missing <>), err -2804
    "pvcompand~"
    ? error: can't fragload pvcompand~ (missing <>), err -2804
    "pvoc~"
    ? error: can't fragload pvoc~ (missing <>), err -2804
    "scrape~"
    ? error: can't fragload scrape~ (missing <>), err -2804
    "shapee~"
    ? error: can't fragload shapee~ (missing <>), err -2804
    "swinger~"
    ? error: can't fragload swinger~ (missing <>), err -2804
    "taint~"
    ? error: can't fragload taint~ (missing <>), err -2804
    "thresher~"
    ? error: can't fragload thresher~ (missing <>), err -2804
    "vacancy~"
    ? error: can't fragload vacancy~ (missing <>), err -2804
    "xsyn~"
    ? error: can't fragload xsyn~ (missing <>), err -2804

    • Apr 04 2006 | 11:37 am
      I can reproduce this on my system. The veclib errors, at least. I don't have FFTease, but InterfaceLib errors are typically the result of trying to use an OS9 object in OSX. I don't know if that's the case here, though. Looks like Apple removed some stuff from the CFM Carbon library in the most recent update. How nice of them.
      jb
    • Apr 04 2006 | 11:43 am
      "sqrt~"
      "!/~"
      "log~"
      There is Problem too...
    • Apr 04 2006 | 11:46 am
      Hi, jb.
      Thank you for replay.
      I try CFM Carbon Lib Update now.
      segeke
      Quote: Jeremy Bernstein wrote on Tue, 04 April 2006 05:37 ---------------------------------------------------- > I can reproduce this on my system. The veclib errors, at least. I don't > have FFTease, but InterfaceLib errors are typically the result of trying > to use an OS9 object in OSX. I don't know if that's the case here, > though. Looks like Apple removed some stuff from the CFM Carbon library > in the most recent update. How nice of them. > > jb > > Am 04.04.2006 um 13:30 Uhr schrieb shigeki tamura: > > I updated it to MacOS10.4.6 today. > > Afterwards, the FFT object and "/~" object of MaxMSP4.5.7 cannot be > > used. > > The error message and the object are the following. > > > > > ----------------------------------------------------
    • Apr 04 2006 | 11:48 am
      Yes, I think for now, users should NOT upgrade to this version of the OS. If it's too late, you'll need to downgrade if you need to use these objects immediately.
      jb
    • Apr 04 2006 | 11:58 am
      after a quick test here, everything seems to be fine. did the upgrade to 4.6 this morning too, with the combo-updater. ? hth hans
      hans w. koch im krahnenhof 11 d-50668 koeln +49-221-554902 www.hans-w-koch.net
    • Apr 04 2006 | 12:00 pm
      >Yes, I think for now, users should NOT upgrade to this version of >the OS. If it's too late, you'll need to downgrade if you need to >use these objects immediately.
      how do you downgrade???
      thanks
      kasper -- Kasper T. Toeplitz noise, composition, bass, computer http://www.sleazeArt.com
    • Apr 04 2006 | 12:26 pm
      Ah, wonderful! OK, confirmed. Running the Combo Updater solves the problem for me, too (even on top of the via-the-Software-Update updated 10.4.6).
      Can you confirm this, Shigeki?
      jb
    • Apr 04 2006 | 12:53 pm
      hi,
      Nice!!!
      This problem was solved.
      segeke
    • Apr 04 2006 | 1:01 pm
      You did make a complete bootable backup of your system before doing the upgrade, didn't you?
      Luckily it looks like you get a second chance this time.
      jb
    • Apr 04 2006 | 1:12 pm
      >You did make a complete bootable backup of your system before doing >the upgrade, didn't you? >
      ha ha ha !!!
      kasper
    • Apr 04 2006 | 3:27 pm
      Hi,
      Anyone know what did apple changed in those libs ?
      Salvator
    • Apr 04 2006 | 4:14 pm
      Looks like there's just a problem with the "delta" updater. Use the "combo" and you won't have a problem.
      jb