problem with gen in standalone

    Mar 02 2012 | 11:16 am
    Hi guys,
    I've made a patch which includes a couple of Gen abstractions which work fine on my laptop but when I compile my patch into a standalone and then run it on a different computer I get an error message in the max window "failed to initialize gen domain gen.dsp" and none of the Gen elements function.
    I understand that this means that the gen element is unable to run as the computer I'm running it on doesn't have Gen but should this not be compiled as part of my standalone?

    • Mar 02 2012 | 11:51 am
      The gen element in fact doesn't work even when I'm running the standalone on the computer on which it was compiled
    • Mar 02 2012 | 9:33 pm
      Are you using 6.0.4? There was a problem with gen and standalones, because it wasn't including all the necessary extensions, but AFAIK this was resolved in 6.0.4.
      Gen should work without any issues in standalones on machines that do not have a Gen license.
    • Mar 02 2012 | 10:19 pm
      Hi Graham,
      Thank you for your response.
      I am using 6.0.4. I've tried compiling it by including the .gendsp file too but this still doesn't work. If there's anything I can do to assist in fixing this please let me know.
    • Mar 03 2012 | 5:09 am
      If you could send me the patches, and details of the machine you are running on (operating system & version mainly), that would be very helpful.
    • Mar 03 2012 | 2:09 pm
      Files and info are on their way to cycling74 support FAO Graham Wakefield.
    • Oct 19 2014 | 1:26 pm
      On Max version 6.1.9 (32nit) on Windows 7 (64 bit), I am getting the same error message. I shared the patch here:
    • Oct 19 2014 | 1:48 pm
      I think 'extensions' are meant to be included for gen~ to work in standalone mode. I was able to get it working by adding an 'extensions' folder to the 'support' folder and copying two files from the max program files extnensions folder" clang.mxe and genpatcher.mxe.