Problem with numbers of parameters in a MSP external object


    Jul 21 2006 | 4:14 pm
    Hello, I have a problem, I want to make an object with default parameters (parameters written in the object's box...) It works for 3 or less parameters, and for 4 and higher, Max/msp is crashing. Can you help me?? Thanks.
    Yohann.
    PS: Sorry for my English but I'm french !! :)

    • Jul 21 2006 | 5:11 pm
      without the name of that object, it's hard to help you... please describe exactly how to reproduce this crash, or send a patch...
      MathieU
    • Jul 21 2006 | 10:14 pm
      On 21-Jul-2006, at 18:14, FABRE wrote: > I have a problem, I want to make an object with default parameters > (parameters written in the object's box...) It works for 3 or less > parameters, and for 4 and higher, Max/msp is crashing. > Can you help me??
      I assume you're trying to build your own external object.
      Max has, for a long time, had difficulties in parsing argument lists in setup() that are longer than 3 items and contain a mixture of A_FLOAT, A_LONG, A_SYM. If everything is A_LONG it apparentlys works fine, but mixed arguments lists don't. The only approach is to use A_GIMME and parse the argument list yourself.
      I don't recall this crashing objects, but it's been a very long time since I tried a long explicit argument list.
      Hope this helps, Peter
      -------------- http://www.bek.no/~pcastine/Litter/ ------------- Peter Castine +--> Litter Power & Litter Bundle for Jitter Universal Binaries on the way iCE: Sequencing, Recording & Interface Building for |home | chez nous| Max/MSP Extremely cool |bei uns | i nostri| http://www.dspaudio.com/ http://www.castine.de