Question about Model and texture behavior in matrixoutput 1 vs 0


    May 19 2007 | 11:47 pm
    hello.
    I have a model that has specific texture coordinates. When I output
    to matrix, it seems as though my texture coordinates are lost and the
    texture projection is different than with matrixoutput 0.
    what do I have to do to maintain the models specific texture
    coordinates when sending out geometry as a matrix?
    (I am using xfade to morph geometry, but not sending to jit.gl.mesh,
    simply appending triangles and sending to jit.gl.render).
    Curious.. :)
    v a d e //
    www.vade.info
    abstrakt.vade.info

    • May 20 2007 | 12:45 am
      On May 19, 2007, at 4:47 PM, vade wrote:
      > what do I have to do to maintain the models specific texture
      > coordinates when sending out geometry as a matrix?
      Coordinates are fine, but the texture is not bound properly, unless
      you bind the texture through jit.gl.render. For example with your
      poser file, I use something like the following in conjunction with
      body_df.jpg, and it seems to work as I would expect. Otherwise, send
      us a clear example of you binding the texture outside jit.gl.model
      (required for textures as applied via matrix output mode to work
      properly AFAICT), and hopefully we can offer some feedback.
      We can look at making this work easier in a future version, but it
      probably won't happen anytime before Max 5 is released.
      Best,
      Joshua
    • May 20 2007 | 1:10 am
      Ah. Thank you sir. I will experiment and report back. I did not
      realize I had to bind the texture separately, thats probably it.
      Thanks again for all the help lately :)
      On May 19, 2007, at 8:45 PM, Joshua Kit Clayton wrote:
      >
      > On May 19, 2007, at 4:47 PM, vade wrote:
      >
      >> what do I have to do to maintain the models specific texture
      >> coordinates when sending out geometry as a matrix?
      >
      > Coordinates are fine, but the texture is not bound properly, unless
      > you bind the texture through jit.gl.render. For example with your
      > poser file, I use something like the following in conjunction with
      > body_df.jpg, and it seems to work as I would expect. Otherwise,
      > send us a clear example of you binding the texture outside
      > jit.gl.model (required for textures as applied via matrix output
      > mode to work properly AFAICT), and hopefully we can offer some
      > feedback.
      >
      > We can look at making this work easier in a future version, but it
      > probably won't happen anytime before Max 5 is released.
      >
      > Best,
      > Joshua
      >
      >
      >
      v a d e //
      www.vade.info
      abstrakt.vade.info
    • May 23 2007 | 9:27 am
      hi Joshua, Vade, other Jitter experts..
      ... just trying to get feedback to a previous unanswered post,
      that I thought would maybe be related to what was told in this last
      thread...
      I'm capturing the result of the render to a texture, to apply it on
      another GL object, somehow as shown in the patch "GLfeedBack" from
      Andrew's jitter recipes.The problem is that my window size is 3840x1024
      (with the amazing triplehead) that is not a power of 2. So I get a
      "chess" rectangle on the right side of the texture which has no
      continuity when set on "repeat" mode. I guess there should be a way to
      extend the capture texture to the next power of 2, or at least to
      interpolate the texture to a size interger of two (as the GPU may not be
      able to handle 4096 x 1024 texture size)
      This was tested with a PC with NVIDIA GeForce 7900 GTX.
      Note that the problem doesn't look same on my powerbook G4 -PPC:
      if i set the jit.gl.texture to "rectangle 1", I have some kind of repeat
      wrap mode but the repetition look very strange (see screenshot attached)
      Though, I know it is mentionned in jitter documentation that this option
      may give strange results..
      It seems the message "rectangle" sent to the jit.gl.texture is making
      the texture use only the relevant part of the texture as stored on the GPU,
      (though I don't know truly what it does) , anyway it is not possible to
      have "repeat" wrap mode on the jit.gl.texture if reactangle is 1.
      I put a simple patch below to show the problem, drawn from Andrew
      Benson's "GL feedback" example
      Thanks for any hint!
      ...vincent