record qt movie in realtime at 25 fps


    Jun 22 2006 | 5:02 pm
    Hi!
    I?m capturing from DV FireWire Cam in MAX.
    i use the jit.qt.record object. I use the realtime option. but I have the problem that the framerates of my captured movies are always different depending on how much cpu power is available for max. but i need every movie at a framerate of 25fps.
    i send this message to start the recording in jit.qt.record:
    write /Users/spierala/Desktop/clip1.mov 25 dvpal
    so why is max ignoring the 25 framerate in this message when I use the realtime option?
    What I need is realtime at framerate 25.
    I also tried to capture directly from the jit.qt.grab object, but I?m working with more cameras and I want to switch between them while recording... I can?t do that with the grab object.
    so who can help me? cheers FLo

    • Jun 23 2006 | 6:55 am
      What version of Jitter are you using? "realtime" mode has gotten a rewrite for the next version of Jitter, and should be much more reliable, FWIW. Note that decompression/recompression from/to DV is not a cheap operation, and it's likely that realtime mode is dropping a lot of frames, in any case. You might consider recording to a lighter compression format (PJPEG, Animation) and then recompressing after you're done.
      jb
    • Jun 23 2006 | 8:27 am
      Hi!
      i?m using jitter 1.2.4
      actually i get enough framerates 25. i can record dv pal at 29 fps. but I want to limit it to 25.
      if I deactivate the realtime option I get a 25 fps movie, but it?s not realtime.
      cheers
      flo
    • Jun 23 2006 | 1:25 pm
      Jitter 1.2.x is not going to be updated for the new realtime mode in Jitter 1.5.3. For Jitter 1.2.4, you may have to use non-realtime mode, with a timing gate to ensure that only 1 frame every 40ms gets to the jit.qt.record object.
      jb
      Am 23.06.2006 um 10:27 schrieb flo spier:
      > > Hi! > > i?m using jitter 1.2.4 > > actually i get enough framerates 25. i can record dv pal at 29 fps. > but I want to limit it to 25. > > if I deactivate the realtime option I get a 25 fps movie, but it?s > not realtime. > > cheers > > flo