sah~ thing i don't seem to understand


    Apr 09 2007 | 5:59 pm
    the following patch, in my mind, once the metro is turned on, should give me an ascending number from the snapshot~. why doesn't it? is there something about sah~ that i am not getting?

    • Apr 09 2007 | 6:12 pm
      you can do it like this:
      jl
    • Apr 09 2007 | 6:13 pm
      Ah...figured this out. Looks like this thread answers the question:
      Modified patch:
    • Apr 09 2007 | 6:24 pm
      Nothing's happening because you have a feedback loop - use send~ and receive~ and it works.
      -- Owen
      joshua goldberg wrote: > the following patch, in my mind, once the metro is turned on, give me > an ascending number from the snapshot~. why doesn't it? is there > something about sah~ that i am not getting? >
    • Apr 09 2007 | 6:25 pm
    • Apr 09 2007 | 6:29 pm
      Because you have feedback in your signal path. Use send~/receive~ if you need to do this. Here is another way you might try and accomplish this same thing:
      best, Andrew B.
    • Apr 09 2007 | 6:32 pm
      Could be a problem with the feedback loop?
      FWIW - As long as that feedback loop is connected, I don't get any measured output from [sah~] at all. Disconnect it and hook up a different input into [sah~] and all is well.
      On Apr 9, 2007, at 11:59 AM, joshua goldberg wrote:
      > > the following patch, in my mind, once the metro is turned on, give > me an ascending number from the snapshot~. why doesn't it? is > there something about sah~ that i am not getting? >
      ---- Steven M. Miller
      Home SFIFEM Atrium Sound Space OVOS
    • Apr 09 2007 | 6:43 pm
      It wasn't sah~. Let me know what you think of this:
      Keith
      On 4/9/07, joshua goldberg wrote: > > the following patch, in my mind, once the metro is turned on, give me an ascending number from the snapshot~. why doesn't it? is there something about sah~ that i am not getting? > > #P toggle 152 118 15 0; > #P window setfont "Sans Serif" 9.; > #P window linecount 1; > #P newex 150 137 52 196617 metro 10; > #P button 94 239 15 0; > #P flonum 98 206 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0; > #P newex 96 177 55 196617 snapshot~; > #P newex 39 72 40 196617 +~ 1.; > #P newex 134 79 55 196617 phasor~ 1; > #P newex 84 110 49 196617 sah~ 0.02; > #P window linecount 3; > #P comment 213 89 100 196617 WHY DOESN'T THE OUPUT FROM SAH~ ASCEND?; > #P connect 7 0 4 0; > #P connect 2 0 1 1; > #P connect 3 0 1 0; > #P connect 8 0 7 0; > #P fasten 1 0 3 0 89 140 10 140 10 39 44 39; > #P connect 1 0 4 0; > #P connect 4 0 5 0; > #P connect 5 0 6 0; > #P window clipboard copycount 9; > >
    • Apr 09 2007 | 7:00 pm
      feedback
      joshua goldberg wrote: > the following patch, in my mind, once the metro is turned on, give me an ascending number from the snapshot~. why doesn't it? is there something about sah~ that i am not getting? > > #P toggle 152 118 15 0; > #P window setfont "Sans Serif" 9.; > #P window linecount 1; > #P newex 150 137 52 196617 metro 10; > #P button 94 239 15 0; > #P flonum 98 206 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0; > #P newex 96 177 55 196617 snapshot~; > #P newex 39 72 40 196617 +~ 1.; > #P newex 134 79 55 196617 phasor~ 1; > #P newex 84 110 49 196617 sah~ 0.02; > #P window linecount 3; > #P comment 213 89 100 196617 WHY DOESN'T THE OUPUT FROM SAH~ ASCEND?; > #P connect 7 0 4 0; > #P connect 2 0 1 1; > #P connect 3 0 1 0; > #P connect 8 0 7 0; > #P fasten 1 0 3 0 89 140 10 140 10 39 44 39; > #P connect 1 0 4 0; > #P connect 4 0 5 0; > #P connect 5 0 6 0; > #P window clipboard copycount 9; > >