Signal to noise optimization in MSP


    Jan 25 2006 | 5:42 pm
    Please excuse this very fundamental question, but how do I ensure that I am achieving the optimum s to n ratio in MSP? I am using a G4 powerpook and a MOTU 828mkII. I have built what is essentially a multi-voice looper to be used with electric guitar. I am about to take the patch out for its first performance, and I think that prospect has heightened my sensitivity to how noisy the patch (or the Max/MSP environment) is. To troubleshoot, I opened a new patch that was nothing but adc~ and dac~ objects connected to each other. Still noisy. The I tried swapping a Presonus Firebox for the MOTU - again, same noise. So I switched back to the 828mkII and ran clean, direct guitar signal to Logic 6 and there was very little noise. So my question is, is MSP just a noisy environment, or is there something in the way Max/MSP and the Mac communicate that's generating excess noise and which I can control.
    Any help would be greatly appreciated.
    Thanks,
    Steve

    • Jan 25 2006 | 6:03 pm
      i don't hear or see any noise when connecting an adc~ to dac~ in 4.5.6 on a Dell tower w/ built-in sound hardware.
    • Jan 25 2006 | 6:22 pm
      Thanks for the reply cebec. Is there anyone out there who *has* experienced noise issues in setup and has overcome them?
    • Jan 25 2006 | 11:36 pm
      i haven't had any problems like this. any internal feedback systems seem totally silent until "seeded" with some sort of intentional audio. is the noise getting into the loops and multiplying (i.e. does it come from your audio input and get amplified by the system), or is it always a consistent noise level?
    • Jan 26 2006 | 11:04 am
      Stephen Griesgraber wrote:
      > Thanks for the reply cebec. Is there anyone out there who *has*
      > experienced noise issues in setup and has overcome them?
      I know of problems with noise which even do not get out of the
      soundcard, but are induced directly into powered speakers (high quality,
      Dynaudios). But inly if the power supply of a Toshiba laptop was plugged
      in. There could be a problem with high energy badly shielded power supplies.
      Changing the power outlet helped, but only a little...
      If the problem is with a laptop try running it on batteries.
      (Apple Powerbooks do not have this problem)
      Stefan
      --
      [][] [][][] [][] [][][] [][] [][][] [][] [][][]
      [][][][][][][][][][][][][][][][][][][][][][][][][][][][]
      Stefan Tiedje
      Klanggestalter
      Electronic Composition
      &
      Improvisation
      /~~~~~
      \ /|() ()|
      ))))) )| | |( \
      /// _/)/ )))))
      ___/ ///
      -------------------------x---
      --_____-----------|----------
      --(_|_ ----|-----|-----()---
      -- _|_)----|-----()----------
      ----------()------------x----
      14, Av. Pr. Franklin Roosevelt, 94320 Thiais, France
      Phone at CCMIX +33-1-49 77 51 72
    • Jan 26 2006 | 2:09 pm
      On 26 janv. 06, at 12:04, Stefan Tiedje wrote:
      > Stephen Griesgraber wrote:
      >> Thanks for the reply cebec. Is there anyone out there who *has*
      >> experienced noise issues in setup and has overcome them?
      >
      I had once noise with a USB Digi001. Replacing the USB cable solved the
      problem.
      p
      _____________________________
      Patrick Delges
      Centre de Recherches et de Formation Musicales de Wallonie asbl
    • Jan 26 2006 | 2:24 pm
      On around Jan 26, 2006, at 12:04, Stefan Tiedje said something like:
      > But inly if the power supply of a Toshiba laptop was plugged in.
      Right: ground loops.
      I carry around a universal mains adapter for my PowerBook, even inside
      Continental Europe (hell, even inside Berlin), for the single reason
      that it doesn't connect to earth/ground.
      > If the problem is with a laptop try running it on batteries.
      > (Apple Powerbooks do not have this problem)
      Mine sure does.
      And, yes, I once did a performance on batteries for the simple reason
      that I forgot to bring my handy-dandy look-ma-no-earth mains plug
      adapter to the gig.
      If a ground loop is the source of Stephen's problem, it's easy to fix
      and will make an enormous difference!
      -- P.
      -------------- http://www.bek.no/~pcastine/Litter/ --------------
      Peter Castine | ^
      | Litter Power & Litter Bundle for Jitter
      pcastine@gmx.net |
      pcastine@bek.no | iCE: Sequencing, Recording, and Interface Building
      4-15@kagi.com | for Max/MSP
      | Extremely cool
      | http://www.dspaudio.com
      | http://www.dspaudio.com/software/software.html
    • Jan 26 2006 | 2:36 pm
      >
      >
      >I carry around a universal mains adapter for my PowerBook, even
      >inside Continental Europe (hell, even inside Berlin), for the single
      >reason that it doesn't connect to earth/ground.
      >
      had the same problem with the (MAC) Pbook G3 - had to take the
      earth/plug off - and quite the opposite with the Alu G4 1.5 Pbook -
      when running it with the NO-EARTH plug (provided by apple) i had once
      big troubles (i was feeling the electricity when touching the pbook)
      plugging the OTHER cable (provided by apple as well) with
      earth/ground solved the problem
      best
      kasper
      --
      Kasper T. Toeplitz
      noise, composition, bass, computer
    • Jan 26 2006 | 2:37 pm
      > I had once noise with a USB Digi001. Replacing the USB cable solved
      > the problem.
      Oooppsss, I meant a mbox, not a digi001 (i'll never be familiar with
      digidesign product line...)
      Sorry.
      _____________________________
      Patrick Delges
      Centre de Recherches et de Formation Musicales de Wallonie asbl
    • Jan 26 2006 | 9:51 pm
      Kasper T Toeplitz wrote:
      > when running it with the NO-EARTH plug (provided by apple) i had once
      > big troubles (i was feeling the electricity when touching the pbook)
      Yeah, thats what I love most about electronic music, without noise but
      being electrified....
      Stefan
      --
      [][] [][][] [][] [][][] [][] [][][] [][] [][][]
      [][][][][][][][][][][][][][][][][][][][][][][][][][][][]
      Stefan Tiedje
      Klanggestalter
      Electronic Composition
      &
      Improvisation
      /~~~~~
      \ /|() ()|
      ))))) )| | |( \
      /// _/)/ )))))
      ___/ ///
      -------------------------x---
      --_____-----------|----------
      --(_|_ ----|-----|-----()---
      -- _|_)----|-----()----------
      ----------()------------x----
      14, Av. Pr. Franklin Roosevelt, 94320 Thiais, France
      Phone at CCMIX +33-1-49 77 51 72