singlefield, jit.qt.grab, 1080i


    Mar 28 2006 | 5:31 pm
    Hi folks,
    I'm successfully bringing in a 1080i video stream using a Kona LHe
    capture card. The camera I'm using is sending a 1080i stream, and the
    card is sending its stream to Jitter as such.
    using the singlefield attribute in jit.qt.grab, i would expect to be
    able to get a deinterlaced image, however it doesn't seem to have any
    effect. downsampling and then interpolating up works, but is taxing
    the cpu. Any suggestions of how else to remedy this process?
    Thanks!
    ~scott

    • Mar 28 2006 | 5:39 pm
      On Mar 28, 2006, at 9:31 AM, Scott Fitzgerald wrote:
      > using the singlefield attribute in jit.qt.grab, i would expect to be
      > able to get a deinterlaced image, however it doesn't seem to have any
      > effect. downsampling and then interpolating up works, but is taxing
      > the cpu. Any suggestions of how else to remedy this process?
      If you upsample by using as a texture, it should be faster than doing
      on the CPU, but I don't believe that jit.qt.movie @singlefield 1 is
      typically any faster than downsampling/upsampling with interpolation
      disabled.
      -Joshua
    • Mar 28 2006 | 7:13 pm
      cool, i'll give that a spin. thank you.
      ~s