Syphon, Resolume and Max/MSP


    Oct 11 2013 | 7:14 pm
    Hi Everyone,
    I'm new to the use of Syphon and I'm trying to received a Jitter matrix from a Max patch inside Resolume. Works well with the Syphon help patch but I don't get an input from my patch.
    I tested everything using simple server / client and I get a visual there.
    I'm assuming that it is down to the alpha channel?
    Any idea, though, experience etc is much appreciated!

    • Oct 12 2013 | 9:53 am
      You have to name your drawto destination very clearly.
      So if your sending from with the client server label it Syphon_out.
      Then make sure your other objects all share the same rendering context.
      ALso make sure that you send the output of jit.gl.render an instruction to create a texture, make that texture go into the max syphon object.
    • Oct 12 2013 | 10:07 pm
      Andro, what do you mean. Can you post a bit of patching ?
      ALso make sure that you send the output of jit.gl.render an instruction to create a texture, make that texture go into the max syphon object.
    • Oct 23 2013 | 12:43 pm
      Andro, that was really helpful..i finally got there!
      Thanks a lot!
    • Oct 23 2013 | 12:58 pm
      Watzlav, can you post an example please ? I get confused with all the texture stuff...
    • Oct 23 2013 | 2:43 pm
      Hey Stephane,
      I don't use Resolume, but I am pretty familiar with VDMX. I am building a visual performance environment around VDMX and Max. It is pretty sweet, I can send bidirectional video between the two and process things freely. This is my syphon server patch, you may find it useful for what you are doing.