Time when not playing in Logic Express


    Jul 08 2006 | 12:39 am
    Am I correct in assuming that the Max timer is halted when playing stops in Logic Express?
    Is this standard for all hosts?
    (I'm trying to re-initialize a plugin whenever PLAY starts, but plugsync~ doesn't ever send a zero out of its first outlet, so I was trying other methods...)
    Example:

    • Jul 08 2006 | 1:02 am
      Hi Arne!
      It is true that in Logic the audio stops running in a plug-in when there is no sound coming into it. In Pluggo, the Max timer is driven by the audio clock - thus in Logic the timers stop when there is no audio.
      This behavior (the audio processing being turned off on you) is not true in most hosts. The other place you might notice it though is in Bias Peak.
      Best wishes! -Tim
      On Jul 7, 2006, at 7:39 PM, Arne Eigenfeldt wrote:
      > > Am I correct in assuming that the Max timer is halted when playing > stops in Logic Express? > > Is this standard for all hosts? > > (I'm trying to re-initialize a plugin whenever PLAY starts, but > plugsync~ doesn't ever send a zero out of its first outlet, so I > was trying other methods...) > > Example: > > max v2; >
    • Jul 11 2006 | 12:29 pm
      Quote: Timothy Place wrote on Sat, 08 July 2006 03:02 ---------------------------------------------------- > Hi Arne! > > It is true that in Logic the audio stops running in a plug-in when > there is no sound coming into it. In Pluggo, the Max timer is driven > by the audio clock - thus in Logic the timers stop when there is no > audio.
      Hi Timothy, this is true, but for some reason audio is not disabled in the selected track in Logic! So you can't depend on this behaviour.
      Arne, I had the same problem. I solved this with the following subpatcher in my plugin:
      Hope that helps, Mattijs