Timing inaccuracy


    May 16 2008 | 11:41 am
    I'm trying to have two videos respond to each other. to do this i need to know where a video is in its loop, so i'm using 'gettime' then triggering video 2 on half the time of the loop from 1.
    the problem is that the time out of jit.qt.movie seems to skip values. for example if a clip is looping between 1000 and 2000 and i have a 'sel 1500', sometimes it bangs it, sometimes it skips the number 1500 and no bang is recorded.
    i have achieved crude success using 'if > 1500 but it is not accurate for my application.
    Why does the time skip values? is there a setting to insure accuracy?
    My video file's frame rate is 25, the metro driving the jit.qt.movie is running at 40. each metro bang triggers a 'gettime' which if accurate would trigger the next movie at a specific value.

    • May 16 2008 | 3:04 pm
      total hack, and still not the exact accuracy you want, but this might
      help. probably don't even need the qlim object. hopefully somebody
      has a better answer....
      --------
      max v2;
      On May 16, 2008, at 7:41 AM, josh wrote:
      >
      > I'm trying to have two videos respond to each other. to do this i
      > need to know where a video is in its loop, so i'm using 'gettime'
      > then triggering video 2 on half the time of the loop from 1.
      >
      > the problem is that the time out of jit.qt.movie seems to skip
      > values. for example if a clip is looping between 1000 and 2000 and
      > i have a 'sel 1500', sometimes it bangs it, sometimes it skips the
      > number 1500 and no bang is recorded.
      >
      > i have achieved crude success using 'if > 1500 but it is not
      > accurate for my application.
      >
      > Why does the time skip values? is there a setting to insure accuracy?
      >
      > My video file's frame rate is 25, the metro driving the
      > jit.qt.movie is running at 40. each metro bang triggers a 'gettime'
      > which if accurate would trigger the next movie at a specific value.
    • May 16 2008 | 4:36 pm
      [> 1500] -> [togedge]
    • May 24 2008 | 8:40 am
      thanks for your help. using the split ive managed to ge it under some control.
      ciao,
      josh