Forums > MaxMSP

AU DLS Synth problem with Snow Leopard

January 26, 2010 | 4:02 am

I have an old MIDI-only patch that I’ve used as a demo for years. It has always worked fine through countless Max and Mac OS updates … until Snow Leopard. I’m still using 10.5.8 on my own computer as well as in my lab at school — no problems. But students who have Snow Leopard installed are unable to get any audio playback through AU DLS synth when they try to use it.

The problem exists on multiple Snow Leopard computers, with multiple versions of Max, with a simple patch file, with a collection, and with compiled stand-alone applications … whether compiled on my machine or on one of my student’s machine. Of course, solving this is complicated by the fact that I don’t have a Snow Leopard machine of my own to test on. Any ideas?

January 26, 2010 | 9:17 am

A quick test of midiout worked here – OSX 10.6.2, Max 5.0.2,
AU DLS shows up as 1st in list – port a. Did you hard code this to something else?
Get them to try this patch

— Pasted Max Patch, click to expand. —

As I said it works for me here – YMMV (Your Maxing May Vary)

January 26, 2010 | 12:12 pm

Max 5.0.8 or higher is required on Snow Leopard in order to have AU DLS Synth working properly. There has been some report of problem with big I/O vector size.

January 26, 2010 | 2:06 pm

That should have read 10.6.2 and Max 5.1.2
Sorry . . .

January 27, 2010 | 1:08 am

Thanks … I’ll try again with updated software. I was using max 5.1.1. At least on student (maybe more) were using 10.6.1

FYI: Without success, we’d tried messing around with vector size (even though there were no MSP objects) and using a simplified patch stripped down to 3 objects: [makenote 127 500] [noteout] (set to AU DLS) and a number box to send notes. But nothing worked.

Viewing 5 posts - 1 through 5 (of 5 total)

Forums > MaxMSP