Forums > MaxMSP

bpatcher and presentation mode

May 29 2008 | 7:03 am

this is an interesting quirk…

I have a patch that I’ve made as a subpatch, with inlets and outlets, to be used inside of a bpatcher. This subpatch looks fairly nice on its own. Its signal flows nicely in edit mode, and the interface is clean in presentation mode.

The problem arises when I encapsulate the subpatch into a bpatcher. It seems that the subpatch remains outside of presentation mode no matter what I do.

So this is either a feature request or a bug fix, depending on how you look at it.

I would be thrilled if I could use the presentation mode layout of my subpatches.

May 29 2008 | 7:33 am

I think someone already posted about this but here goes again. It’s neither a bug nor a feature request since the feature already exists! :) Make sure the patcher’s inspector has "open in presentation" checked (the one you want in the bpatcher). To get to that setting I ctrl+click on a blank spot in the patch, or right+click or you can type shift+apple+i or go view->patcher inspector. If you already did that and have the problem that’s another matter…..

May 29 2008 | 7:47 am

ohhhh geez!

instant gratification!

I searched, but couldn’t come up with anything.

thanks for the tip!

Viewing 3 posts - 1 through 3 (of 3 total)

Forums > MaxMSP