Forums > MaxMSP

buffer~ record~ waveform~ help

Apr 16 2014 | 2:36 am

For whatever reason, maybe it’s time to go to bed, but I can’t seem to figure this out.

My buffer’s waveform shows that it is indeed recording my audio input, but my groove~ object won’t play. I had it working a bit ago but was messing around and have gotten myself into a place where my eyes cannot see the space brain error I must be making.

Additionally wondering how to get the waveform/buffer/record play length to change. When I change the play length or record length in buffer~ or record~ I don’t see the waveform~ update, or hear a length change so bleh

n00b space

thanks for any help

  • This topic was modified 2 years by  vista.
  1. whyaya.maxpat
Apr 16 2014 | 1:15 pm

Here you go.

This worked for me. Just removed the *~ because it wasn’t in use. If you left it at this, it may have not played through for this reason. If you set the argument to 1 it should go through as is ("*~ 1"). The display on waveform~ should change as you adjust the size of the buffer or replace a sample. This worked for me without issue when I looked at your patch.

  1. whyaya1.maxpat
Apr 17 2014 | 5:38 pm

Thank you, that works. However,…

I copied this out of another patch where there are two sfplay~ objects, could this be interfering with groove? Because I discovered when moving your rendition of my patch back into the main piece that it no longer works either. Only when I have it opened in a separate patch window does it work. I discovered the same thing with my original patch, there was never any error in patching, perhaps just interference between sfplay~ and groove~?

thanks for your help

Viewing 3 posts - 1 through 3 (of 3 total)

Forums > MaxMSP