Forums > Jitter

BUG! NSColorPikerUser/NXColorPickerSliders menus appears randomly in my patch.



LLT
Mar 09 2012 | 5:33 pm

Hi
Before Max 6.0.4 was systematically (after some time) using jit.gl.material or inspector on an object.

Incredible! before finishing this post I go into fullscreen in my patch and NXColorPickerSliders menu appears.

If I move up to the NXColorPickerSliders my Mac no longer works for 10 seconds!!

Mac OS 10.7.3
max 6.0.4
Mac Mini 2.4 Ghz Core 2 Duo
8GB ram
NVIDIA GeForce 320M

{
"NVIDIA GeForce 320M OpenGL Engine" : {
"Vendor Name" : "NVIDIA Corporation",
"Version" : "2.1 NVIDIA-7.18.11",
"GLSL Version" : "1.20",
"Renderer Properties" : {
"OffScreen" : 0,
"FullScreen" : 1,
"RendererID" : 16918042,
"Accelerated" : 1,
"Robust" : 0,
"BackingStore" : 1,
"Safe" : 1,
"Window" : 1,
"MultiScreen" : 0,
"Compliant" : 1,
"DisplayMask" : 3,
"BufferModes" : 15,
"ColorModes" : 167805440,
"AccumModes" : 8421376,
"DepthModes" : 3073,
"StencilModes" : 129,
"MaxAuxBuffers" : 2,
"MaxSampleBuffers" : 1,
"MaxSamples" : 8,
"SampleModes" : 2,
"SampleAlpha" : 1,
"VideoMemory" : 268435456,
"TextureMemory" : 239075328,
"GPUVertProcCapable" : 1,
"GPUFragProcCapable" : 1,
"Online" : 1
}
,
"OpenGL Limits" : {
"Framebuffers" : {
"MAX_COLOR_ATTACHMENTS_EXT" : [ 8 ],
"MAX_RENDERBUFFER_SIZE_EXT" : [ 8192 ],
"MAX_VIEWPORT_DIMS" : [ 8192, 8192 ],
"MAX_DRAW_BUFFERS_ARB" : [ 8 ],
"MIN_PBUFFER_VIEWPORT_DIMS_APPLE" : [ 32, 32 ],
"SUBPIXEL_BITS" : [ 8 ]
}
,
"Points and Lines" : {
"ALIASED_LINE_WIDTH_RANGE" : [ 1, 10 ],
"ALIASED_POINT_SIZE_RANGE" : [ 1, 63 ],
"SMOOTH_LINE_WIDTH_GRANULARITY" : [ 0.125 ],
"SMOOTH_LINE_WIDTH_RANGE" : [ 0, 10 ],
"SMOOTH_POINT_SIZE_GRANULARITY" : [ 0.125 ],
"SMOOTH_POINT_SIZE_RANGE" : [ 1, 63 ]
}
,
"Stacks" : {
"MAX_ATTRIB_STACK_DEPTH" : [ 16 ],
"MAX_CLIENT_ATTRIB_STACK_DEPTH" : [ 16 ],
"MAX_COLOR_MATRIX_STACK_DEPTH" : [ 10 ],
"MAX_MODELVIEW_STACK_DEPTH" : [ 32 ],
"MAX_NAME_STACK_DEPTH" : [ 128 ],
"MAX_PROGRAM_MATRIX_STACK_DEPTH_ARB" : [ 2 ],
"MAX_PROJECTION_STACK_DEPTH" : [ 10 ],
"MAX_TEXTURE_STACK_DEPTH" : [ 10 ]
}
,
"Textures" : {
"MAX_3D_TEXTURE_SIZE" : [ 2048 ],
"MAX_CUBE_MAP_TEXTURE_SIZE" : [ 8192 ],
"MAX_RECTANGLE_TEXTURE_SIZE_EXT" : [ 8192 ],
"MAX_TEXTURE_SIZE" : [ 8192 ],
"MAX_TEXTURE_LOD_BIAS" : [ 15 ],
"MAX_TEXTURE_MAX_ANISOTROPY_EXT" : [ 16 ],
"MAX_TEXTURE_UNITS" : [ 8 ]
}
,
"Shaders" : {
"MAX_COMBINED_TEXTURE_IMAGE_UNITS_ARB" : [ 16 ],
"MAX_FRAGMENT_UNIFORM_COMPONENTS_ARB" : [ 4096 ],
"MAX_TEXTURE_COORDS_ARB" : [ 8 ],
"MAX_TEXTURE_IMAGE_UNITS_ARB" : [ 16 ],
"MAX_VERTEX_ATTRIBS_ARB" : [ 16 ],
"MAX_VERTEX_TEXTURE_IMAGE_UNITS_ARB" : [ 16 ],
"MAX_VERTEX_UNIFORM_COMPONENTS_ARB" : [ 4096 ]
}

}

}
,
"Apple Software Renderer" : {
"Vendor Name" : "Apple Computer, Inc.",
"Version" : "2.1 APPLE",
"GLSL Version" : "1.20",
"Renderer Properties" : {
"OffScreen" : 1,
"FullScreen" : 0,
"RendererID" : 16909312,
"Accelerated" : 0,
"Robust" : 1,
"BackingStore" : 1,
"Safe" : 1,
"Window" : 1,
"MultiScreen" : 1,
"Compliant" : 1,
"DisplayMask" : 3,
"BufferModes" : 13,
"ColorModes" : 134250496,
"AccumModes" : 536870912,
"DepthModes" : 4097,
"StencilModes" : 129,
"MaxAuxBuffers" : 4,
"MaxSampleBuffers" : 1,
"MaxSamples" : 16,
"SampleModes" : 1,
"SampleAlpha" : 1,
"VideoMemory" : 0,
"TextureMemory" : 0,
"GPUVertProcCapable" : 0,
"GPUFragProcCapable" : 0,
"Online" : 1
}
,
"OpenGL Limits" : {
"Framebuffers" : {
"MAX_COLOR_ATTACHMENTS_EXT" : [ 8 ],
"MAX_RENDERBUFFER_SIZE_EXT" : [ 16384 ],
"MAX_VIEWPORT_DIMS" : [ 16384, 16384 ],
"MAX_DRAW_BUFFERS_ARB" : [ 8 ],
"MIN_PBUFFER_VIEWPORT_DIMS_APPLE" : [ 1, 1 ],
"SUBPIXEL_BITS" : [ 10 ]
}
,
"Points and Lines" : {
"ALIASED_LINE_WIDTH_RANGE" : [ 1, 64 ],
"ALIASED_POINT_SIZE_RANGE" : [ 1, 64 ],
"SMOOTH_LINE_WIDTH_GRANULARITY" : [ 0.0001 ],
"SMOOTH_LINE_WIDTH_RANGE" : [ 0, 64 ],
"SMOOTH_POINT_SIZE_GRANULARITY" : [ 0.0001 ],
"SMOOTH_POINT_SIZE_RANGE" : [ 0, 64 ]
}
,
"Stacks" : {
"MAX_ATTRIB_STACK_DEPTH" : [ 16 ],
"MAX_CLIENT_ATTRIB_STACK_DEPTH" : [ 16 ],
"MAX_COLOR_MATRIX_STACK_DEPTH" : [ 10 ],
"MAX_MODELVIEW_STACK_DEPTH" : [ 32 ],
"MAX_NAME_STACK_DEPTH" : [ 128 ],
"MAX_PROGRAM_MATRIX_STACK_DEPTH_ARB" : [ 2 ],
"MAX_PROJECTION_STACK_DEPTH" : [ 10 ],
"MAX_TEXTURE_STACK_DEPTH" : [ 10 ]
}
,
"Textures" : {
"MAX_3D_TEXTURE_SIZE" : [ 16384 ],
"MAX_CUBE_MAP_TEXTURE_SIZE" : [ 8192 ],
"MAX_RECTANGLE_TEXTURE_SIZE_EXT" : [ 16384 ],
"MAX_TEXTURE_SIZE" : [ 16384 ],
"MAX_TEXTURE_LOD_BIAS" : [ 16 ],
"MAX_TEXTURE_MAX_ANISOTROPY_EXT" : [ 16 ],
"MAX_TEXTURE_UNITS" : [ 8 ]
}
,
"Shaders" : {
"MAX_COMBINED_TEXTURE_IMAGE_UNITS_ARB" : [ 16 ],
"MAX_FRAGMENT_UNIFORM_COMPONENTS_ARB" : [ 4096 ],
"MAX_TEXTURE_COORDS_ARB" : [ 8 ],
"MAX_TEXTURE_IMAGE_UNITS_ARB" : [ 16 ],
"MAX_VERTEX_ATTRIBS_ARB" : [ 16 ],
"MAX_VERTEX_TEXTURE_IMAGE_UNITS_ARB" : [ 16 ],
"MAX_VERTEX_UNIFORM_COMPONENTS_ARB" : [ 4096 ]
}

}

}

}

[attachment=187773,3510] [attachment=187773,3511]

Attachments:
  1. Capturedcran2012030918.14.48.png

    Capturedcran2012030918.14.48.png


LLT
Mar 14 2012 | 9:58 pm

The mysterious menus:NSColorPikerUser – NXColorPickerSliders

I’m the only one having this problem?

LLT


LLT
Mar 14 2012 | 11:30 pm

I try to reproduce the bug with jit.gl.material.
the mysterious NSColorPikerUser menu is back!!!

Else by selecting randomly dirt.wall or pavement.crackle in jit.gl.material
this error message :
jit.gl.mesh: unbinding vertex array: GL Error: Invalid operation.

I seem to have much problem with jit.gl.material at home
There is no one to confirm the same problems with jit.gl.material?

LLT


LLT
Mar 22 2012 | 5:42 pm

Hello Everyone

The mysterious menus : NSColorPikerUser – NXColorPickerSliders.

And dirt.wall or pavement.crackle in jit.gl.material
this error message :
jit.gl.mesh: unbinding vertex array: GL Error: Invalid operation.

I’m the only one having this problem?

LLT

Apr 14 2012 | 9:35 am

Sometimes that menu appears to me too.
I don’t know why.

Max 6.0.4
Lion
MacBookPro


ak
Apr 29 2012 | 12:52 am

Same here! NXsomething windows without close button.

[Max 6.0.4, Mac OS 10.7.3 on MBP]

Apr 29 2012 | 7:49 am

I observed that menu sometimes appears after I set window fullscreen.


dtr
Apr 29 2012 | 9:39 am

I see ‘m appear from time to time as well. Max 6.0.4, OSX 10.7.3


LLT
May 07 2012 | 9:48 pm

NSColorPikerUser – NXColorPickerSliders BUG
The same with Max 6.0.5 :(

The black bar in fullscreen with umenu
The same with Max 6.0.5 :(

Oct 01 2012 | 2:33 pm

After a session with the Physics patch-a-day series of tutorials, hence working with materials, worlds, etc, I also get a number of these windows. I’m on Max 6.0.7 on OSX 10.8.2


Spa
Oct 02 2012 | 3:49 pm

me too 6.0.7
going fullscreen

Oct 02 2012 | 8:06 pm

I used to have this problem but I deleted Max, removed the preferences then reinstalled and I don’t have it anymore !

I still have a tiny window appearing at the bottom of my screen though… But it’s only once a session.

2 x 2.8 Quad Core Mac Pro (ATI 4870)

Oct 04 2012 | 3:22 pm

can anyone confirm if this problem only happens when there is a secondary display connected?


LLT
May 05 2013 | 9:48 am

Hello Rob
NSColorPikerUser – NXColorPickerSliders BUG
is always with Max 6.1.2
I confirm that this problem occurs only when there is a secondary display connected.

Sorry for the late reply.
LLT

May 05 2013 | 10:13 am

Same here, I have a 2.3 GHz Intel Core i7 (not the retina) without any secondary display (Max 6.1.2).

May 27 2013 | 11:40 pm

This has been happening to me as well.  Possibly related to fullscreen mode.. possibly related to viewing some of the jitter examples.

 

max 6.1.2 (6a3e522) (32-bit)

macbook pro 2.6 Core i7  OS X 10.8.3

no secondary display

 

May 28 2013 | 1:05 am

Same here 6.1.2, osx 10.8.3, working on video through openGL. Also happened with some previous versions but can’t tell which ones. But unlike the OP, the window is blank, just the window title.


LLT
Dec 13 2013 | 6:57 am

hello, always the same problem with mac os 10.9 and max 6.1.6.
One monitor or two monitors is the same.

LLT

Viewing 18 posts - 1 through 18 (of 18 total)

Forums > Jitter