Forums > Dev

build error Max MSP UB SDK examples (Xcode)


Dec 20 2006 | 1:32 pm

Hello all,

I am new to externals and I started reading this article (http://www.cycling74.com/twiki/bin/view/ProductDocumentation/GettingStarted) to get started. When I tried to build the examples, I received this error:

/usr/bin/ld: warning /Developer/SDKs/MacOSX10.4u.sdk/Library/Frameworks/MaxAPI.framework/MaxAPI cputype (18, architecture ppc) does not match cputype (7) for specified -arch flag: i386 (file not loaded)

I am using a new Intel based Mac, the new UB SDK, and the new Xcode. I am also quite positive that I have followed the instructions in the article correctly. Any help is appreciated, I am not too familiar with Xcode.

Dec 20 2006 | 5:17 pm

open up the project’s target settings and change the ‘arch’ property
from ppc to i386.

wes

On 12/20/06, Benjamin Eckel wrote:
>
> Hello all,
>
> I am new to externals and I started reading this article (http://www.cycling74.com/twiki/bin/view/ProductDocumentation/GettingStarted) to get started. When I tried to build the examples, I received this error:
>
> /usr/bin/ld: warning /Developer/SDKs/MacOSX10.4u.sdk/Library/Frameworks/MaxAPI.framework/MaxAPI cputype (18, architecture ppc) does not match cputype (7) for specified -arch flag: i386 (file not loaded)
>
>
> I am using a new Intel based Mac, the new UB SDK, and the new Xcode. I am also quite positive that I have followed the instructions in the article correctly. Any help is appreciated, I am not too familiar with Xcode.
>

Dec 20 2006 | 5:21 pm

it seems from the error you are somehow you’re building ppc only code…
check that you have the latest version of the MAX sdk. and that xcode
is building the correct architecture target.

On 12/20/06, Benjamin Eckel wrote:
>
> Hello all,
>
> I am new to externals and I started reading this article (http://www.cycling74.com/twiki/bin/view/ProductDocumentation/GettingStarted) to get started. When I tried to build the examples, I received this error:
>
> /usr/bin/ld: warning /Developer/SDKs/MacOSX10.4u.sdk/Library/Frameworks/MaxAPI.framework/MaxAPI cputype (18, architecture ppc) does not match cputype (7) for specified -arch flag: i386 (file not loaded)
>
>
> I am using a new Intel based Mac, the new UB SDK, and the new Xcode. I am also quite positive that I have followed the instructions in the article correctly. Any help is appreciated, I am not too familiar with Xcode.
>


Cheers!
Andrew Burgess

Dec 20 2006 | 10:30 pm

Okay, I changed the architecture to i386. That didn’t work so I changed it to i386 and PPC and that worked for some reason. Either way, thanks for the quick and accurate responses fellows.

Dec 20 2006 | 10:41 pm

Actually, sorry, I thanked too soon. The Max environment is giving me an error saying it cannot find executable for CFBundle (0x16090bf0) and won’t load the instance.

Dec 20 2006 | 10:46 pm

Nevermind, it appears that I did in fact download the wrong SDK even though I thought I was almost positive. My old one says UB but it doesn’t have the same stuff as the one I just downloaded. Anyway, that was it. So thanks, again.

Viewing 6 posts - 1 through 6 (of 6 total)

Forums > Dev