Forums > Dev

Building an Application

Feb 21 2006 | 9:29 am

Hi list !
I’ve benn trying to build an application from a patch that uses an
XCode-made mxo external called JazzInterface. However I keep getting
an error "cannot open JazzInterface.mxo" when building, and when
executing the resulting app the same object cannot be found. Is this
a known behavior with mxo objects ? Can anyone help ?

Thanks in advance,

Axel Balley
45, cours Alsace-Lorraine

Feb 21 2006 | 7:46 pm

I’ve never successfully gotten the build script to toss the mxo into
my bundles. Put it in there manually by right-clicking the app,
choosing show contents and then put the mxo into either the root of
the contents, or into the MacOS directory.

I also find that I need to have people I give my mxo’s toss the Max
and MaxAPI frameworks onto their system. The easiest way is to ask
them to install the demo of Max/MSP, but just putting the frameworks
on there might be enough.


Feb 22 2006 | 4:09 pm

Hi all,

sure it wouldn’t be the most efficient way (space-wise), but has anyone
tried to put the frameworks into the bundle. The bundle architecture
supports private or local bundles, but i’ve never tried whether they are
automatically found.

best greetings,

PS. I’m happy about the existence of this resurrected Max-dev mailing
list. It has become impossible for me to follow the general Max list
because of the incredible volume of postings.

Viewing 3 posts - 1 through 3 (of 3 total)

Forums > Dev