Forums > MaxMSP

can max still not record a multi-channel wav file?

February 21, 2014 | 11:52 am

hi all,

i’d like to record the output of my 8-channel patches into 8-channel WAV files, but it seems like it can’t be done?

with the simple patch below, i can record 8-channel AIFF files just fine, but not the WAV format, which is what i tend to work in. the AIFF will import into pro tools etc. without problems, but the WAV file is rejected..

maybe i’m missing something. thanks for any hints!

i’m using max 6.1.6 under OS X 10.9.1


— Pasted Max Patch, click to expand. —


February 21, 2014 | 12:42 pm

There are a few topics about this on the forum.
I spent quite some (useless, I’m afraid) time on this one:

I don’t use WAVE in Max anymore, so I didn’t test recently. I’ll do it on monday. And may send another mail to support…

It took many years to fix the peek~ at index 1000 bug, so just be patient a couple more years…

February 21, 2014 | 12:47 pm

thanks for the feedback.

i’ve seen some of the other topics. was just hoping someone had found a solution, or that the bug had been fixed but that i made some other mistake myself. the forum search feature is a little spartan so i might have missed more recent posts.

every nun needs a synthi!

February 21, 2014 | 1:16 pm

seriously, why not AIFC?

February 21, 2014 | 1:27 pm

i’ll use AIFC if i can’t use WAV, but most of my clients require WAV files so that’s what i tend to use..

February 22, 2014 | 1:06 am

I’m sure I’ve had multichannel Wavs from sfrecord~ to Pro tools working before… Will try to find the patch. Have you tried it with samptype as float32?

February 22, 2014 | 1:15 am

I just found a 20 channel file .wav written with sfrecord~ which I just imported into pro tools 8. It is 16bit, 44.1, 20 channel.

  1. multi


February 22, 2014 | 10:19 am


every nun needs a synthi!

So you have identify me. Amen!

Nuns also need Max these days, but AKS is definitively more fun than computing.

February 24, 2014 | 1:34 am

@Mark: you’re on a PC!

I confirm it still doesn’t work to save multitracks WAVE files (I tried with int16). None of the software I tried on OSX can open them, even Max :-) (I don’t own PT).
So, nothing new since 2010…

When I need multitrack WAVE files (most of the time for a small multitrack SDcard reader), I build them with Audacity, which is very handy for this purpose.

February 24, 2014 | 3:06 am

thanks very much for the feedback everyone!

AIFF it is then, for now.

March 27, 2014 | 3:47 am

This has been an annoyance for a long time… AIFF isn’t a solution for me due to incompatibility in the third-party player I use (my solution is to use MATLAB to write these files instead of MSP…)

One thing that I’ve noticed is that looking at a "multichannel wav" (6-channels, 44.1 kHz, 16 bit) file made in MSP using Media Inspector shows the following Audio Stream info:

CODEC: 01000000-0000-3F00-0000-1000800000AA
CODEC (FourCC): 01000000-0000-3F00-0000-1000800000AA
All other data seem normal.

If I write the same file using MATLAB (which is playable on my other devices), I get
CODEC (FourCC): 1

The Container Stream info for both files match each other.

It’d be REALLY nice to get this fixed… please?


March 28, 2014 | 3:57 pm

There is the argument that an Audio Player that doesn’t support AIFF is, by definition, broken (or at least lame). But that probably doesn’t help you.

There are a couple of gazillion audio format converters that will help you, however.

I don’t know what platform you’re on. FWIW, on a lazy day I’ll use iTunes to convert, but there are more tech geeky things around, like SoX.

March 31, 2014 | 6:12 am

It’s not hard to find a hardware player that plays FLAC and WAV but not AIFF. As only one example, the Cambridge Azur 752 Blu-ray player. Personally, I wouldn’t consider that "broken" – certainly not "by definition" just because it doesn’t support AIFF…

Additionally, since part of my job is to test hardware that plays multichannel WAV (but not AIFF), I need a tool that can reliably make such a file. It would be nice if MSP could do this so that I could stop using MATLAB to do it instead – particularly since so much of my testing is currently done using MSP.

Of course, a third-party converter could work, but that’s certainly not a very elegant solution to what appears, at least from the outside, to be a basic bug.


April 23, 2014 | 2:27 am

6.1.7 under X.9.2 doesn’t help :(

sfplay~ can read multi-channels WAVEs created with sfrecord~, but no other software I tried can.
Even Max’ own file browser still can’t, I get this error:
imovie: error -208 calling NewMovieFromDataRef while opening 4tracks__snd.wav

Viewing 14 posts - 1 through 14 (of 14 total)

Forums > MaxMSP