Forums > MaxMSP

Clock drifts (again!)


August 13, 2011 | 12:29 pm

Hi all, 

After having solved a *several*-months problem turning from Soundfower to Jack to avoid clock drifts ( which caused me a lot of crackles and pops after a while) you can imagine how happy I was few days ago to discover that clock drifts have returned since I started using transport to manage my rhythms. I’m really, really under a big problem for my patch needs to be ready very soon and I’m struggling to find a solution to avoid those crackles/pops which are happening again. 
Does anybody know how to fix it? Please please please!

Thanks!

August 16, 2011 | 7:08 pm

I have no idea what your patch is like so…

– turn on audio interrupt, mess with vector size and all that.
– increase your soundcards buffer size
– try your patch on a more powerful comp (just to see)
– check that it is 44.1 throughout or whatever SR you are using
– maybe try making a phasor~ based clocking system
– tie your system to an external clock like Big Ben or an MPC or something external (see if it helps)
– turn off processes individually to see if it is any particular process is causing the problems.
– turn off background processes on your computer – anti virus, bluetooth, wi-fi, updaters – everything that can be turned off.

Nothing more helpful than that I am sorry.

Viewing 2 posts - 1 through 2 (of 2 total)

Forums > MaxMSP