Forums > MaxMSP

edge~ not working inside subpatch within poly~

Jul 01 2013 | 7:04 am

Hello! Hoping there is a simple explanation –

I have a sub-patch within a poly~ containing an edge~ which is not sending bangs at all. This is an LFO patch with 1 voice so I can utilize down-sampling, and before stuffing it into a poly~ everything worked fine. Actually, everything works fine except this edge~. The signal is indeed going to it – this thing should be banging constantly.

Any ideas?

Jul 01 2013 | 7:18 pm

What are you detecting with edge~? I’m assuming it’s from a phasor~…

If you’re using phasor~ avoid using ==~ 0 or lessthan~ 0.001

I use the following and it works well:
>~ 0.5

The abs~ is there so it doesn’t matter if your frequency is negative. The pulse from >~ 0.5 is exactly one sample long, so it works well with things like +=~ if you want to count pulses at signal rate.

Jul 01 2013 | 8:34 pm

I’m using phasor~ to >=~ 0.5 to edge~. When I got home today and fired up the patch it worked fine. Not sure what was going on earlier. I appreciate the help though, Peter. Your way looks pretty fool-proof.

Viewing 3 posts - 1 through 3 (of 3 total)

Forums > MaxMSP