Forums > MaxMSP

Failed attempts to control Cuemix FX via OSC


September 11, 2013 | 4:12 am

I tried to get Cuemix controlled via osc, as it is possible to do that with TouchOSC, I thought it should work easily. But it doesn’t…

Thats what I tried: First I analyzed the osc messages from the Motu cuemix touchosc template.
TouchOsc is sending for example this message for the first slider:

/bin/fvEB+0/fvInCS+0/cdf 0.497549

I connected TouchOSC to Cuemix, and TouchOSC is telling me its sending on port 53497.

Then I tried to send the above message to the ip of my Macbook (code at the end of the post)
I also tried localhost and a broadcast 255.255.255.255…
But Cuemix does not move the slider…

I have no idea why this is failing…
There is also some kind of handshaking between TouchOSC and Cuemix happening. But I don’t know what how it is happening there.
TouchOSC does see Cuemix as Host, but it does not see Max as host. The host is delivering the information about the ports to TouchOSC.
In Cuemix I do see my iPad as TouchOSC device. I want to make it think my Maxpatch is a TouchOSC device as well… But how to achieve this…?

Has anybody got a cuemix control of any kind working? (The HUI Protocol might be an option as well…)

<code>

– Pasted Max Patch, click to expand. –

</code>

December 27, 2013 | 8:43 am

Hi Stefan,

I am using Max to establish a OSC connection to CueMixFX and control volumes of all busses with a MIDI controller: http://blog.sebastian-arnold.net/2013/11/a-portable-digital-mixing-desk-with-maxmsp/

If you want to dig deeper, you will have to check the OSC messages in the TouchOSC templates of the MOTU driver (see http://www.motunation.com/forum/viewtopic.php?f=2&t=50984). I have attached an example patch that uses osctools. Hope it works!

<code>

– Pasted Max Patch, click to expand. –

</code>

Sebastian

December 27, 2013 | 9:12 am

Hey,
This is very interesting for some motu devices owners :) thanks for the infos !

February 24, 2014 | 2:57 pm

Hey,
i’m trying to dig into this at the moment, and can’t understand several things…
*i don’t have touchOSC, apparently it’s used because it has a built-in template for communicating with CueMix right ? this template that "sc7" at that motunation thread reverse engineered and which is there http://pastehtml.com/view/cdh38i82b.rtxt, is that it ?
*so, one has to set CueMix in "OSC enabled" mode, but how ?…
*on which channel does CueMix send osc informations ?
Thanks, hoping someone will find it (i see dhjdhjdhj took part in that motunation conversation, maybe if he reads that… aaah, if only there was some kind of private messaging system…)

February 24, 2014 | 3:23 pm

Ok, so i just updated my motu softwares and voilà ! there is an osc enable option in cuemix fx (menu "control surfaces"). I should be going better now. Will report later if it works.

February 27, 2014 | 3:30 pm

What do the zeroconf objects do in Sarnold’s patch ? i’m lost ! .. i can receive osc messages from CueMix, but had no luck sending any of them.

February 27, 2014 | 3:33 pm

i also don’t understand what is meant by the "HACK NEEDED" paragraph……….

February 28, 2014 | 5:25 pm

It works !….

March 3, 2014 | 12:39 pm

I just got a roughly working connection from my Fostex MixTAB Midi controler to the CueMix controlling a Motu UltraLite mkIII hybrid with the below project. For your own needs just replace the mtlin subpatcher with your own connection to your controller.
This is far from being ready, not all potentiometers are connected yet, but (hopefully) you get the idea…
The patch has to act as if it is a TouchOSC on an iPad. The feedback from CueMix only happens if CueMix assumes a specific view on the iPad. This is unnecessarily difficult, but MotU seems to think along "why easy if it could be complicated…;-)"

MixTAB2CueMix

have fun…

March 3, 2014 | 1:23 pm

hah, so that explains the necessity of the zeroconfs objects to declare as a "touchOSC like" device name ? btw i got it to work, modifiying Sarnold’s patch ; i found it just right before the gig ;)

November 8, 2014 | 7:55 am

Sorry to reply to such an old threat, but @VICHUG, could you please point me in the right direction of how you solved this?

I installed the osctools, downloaded the patch of @Sarnold and changed the string "MOTU 828mk3 Hybrid CueMix FX OSC" to "MOTU 828mk3 FireWire CueMix FX OSC". There is no connection to CueMix FX at all. The status-light in the patch doesn’t light up too.

I’m struggling with the setup in CueMix FX itself too. I enabled the control surfaces but didn’t add or edit anything in the OSC devices window.

November 9, 2014 | 4:53 am

Hi everybody,

it is somewhat difficult to figure out how the CueMix FX OSC interface works. This is a rough outline:

1. CueMix is constantly looking for OSC clients that are announced via Zeroconf and have a name that ends with "(TouchOSC)". In my example this is Max on port 64711.
2. CueMix announces itself via Zeroconf with the name "MOTU 828mk3 Hybrid CueMix FX OSC on 127.0.0.1" or similar. If you have a different device, you have to change these two Strings to the matching device. Attach a print object to zeroconf.browser to find our your device string.
3. You may need to register your client in CueMix under "Control Surfaces"->"Configure OSC devices…"
4. IMPORTANT: my example patch relies on loadbang and loadmess objects. Please save it to disk and reload in order to start the connection.

One more word about that strange HACK NEEDED paragraph:

The CueMix client is not stateless. That means, you cannot control EQs and Faders (or different channel banks) at the same time, because you need to switch the mode to /mixes or /eq before these commands will work. The trick is to implement multiple OSC clients and use them simultaneously, e.g. one for the mix, the other for the EQ.

I hope it will work like that for you. I’ve been playing over 50 live shows in the past months without a screen attached, using this connector without failure (except the usual MOTU firewire/USB driver hickups, but that’s a different story).

Best,
Sebastian

  • This reply was modified 3 months by  sarnold.
November 9, 2014 | 5:20 am

@Henny : aditionnally, depending on your OS, you might have a problem with your network configuration. I’m on Mac 10.6.8, and the connection wouldn’t establish sometimes because a local networking service wasn’t activated by default by OSX ; those cases were solved by creating an ad-hoc network via airport from my computer..; (even with nothign on the network). After discussing the subject on the irc of MacPort, this problem appeared to be very os specific apparently, and may or may not be solved with this. And i don’t really understand it. IIRC there is a network observer tool on osx, and you can check from there if the address is there… don’t remember which address it was (just "localhost" maybe ?), and my computer is beeing repaired now so can’t help you more (*if* that were to be your problem).
What is your Max window saying ?

November 14, 2014 | 4:48 pm

Thank you very much for the replies guys! Unfortunately simply not working at all.

Max window error for the zeroconf.browser is:

zeroconf.service: unable to load object bundle executable
 2014-11-15 01:46:11.954 Max[7289:985210] Error loading /Applications/Max 6.1/Cycling '74/External/zeroconf.service.mxo/Contents/MacOS/zeroconf.service:  dlopen(/Applications/Max 6.1/Cycling '74/External/zeroconf.service.mxo/Contents/MacOS/zeroconf.service
 , 262): no suitable image found.  Did find:
 	/Applications/Max 6.1/Cycling '74/External/zeroconf.service.mxo/Contents/MacOS/zeroconf.service: no matching architecture in universal wrapper

So the mxo’s aren’t loading properly thus not doing anything. I’m using ableton + max 64bit. Could it be that the mxo’s are compiled for 32bit or couldnt that be the problem?

November 15, 2014 | 2:20 pm

that very much could be ! generally if an external is not said as beeing compiled for 64 bit/ was created before max 6.1 went out, it won’t work in 64 bits.

  • This reply was modified 3 months by  vichug.
Viewing 15 posts - 1 through 15 (of 15 total)