Forums > MaxMSP

folder bug ?

Feb 27 2009 | 3:02 pm

Hi there,

another rather simple but annoying issue. I am using the relative path syntax to access certain directories located within the Max application directory.

Using "./" works in the full Max version, but the very same patch returns an error when executed in the Runtime.

It can be demonstrated quite easily by creating a collective out of the folder.maxhelp patch and opening it with Runtime.

There will be an error "./Cycling’74/max-help: not a folder". The same patch (even using the collective !!) works in the full version.

Feb 27 2009 | 3:20 pm
monohusche wrote on Fri, 27 February 2009 16:02
There will be an error "./Cycling’74/max-help: not a folder". The same patch (even using the collective !!) works in the full version.

I can’t reproduce that on mac. I created an application with folder’s help file, the error only appears if there’s no folder "Cycling ’74/max-help" at the same level as the application, if there’s it’s properly found:

./Cycling ’74/max-help

Feb 27 2009 | 4:06 pm

Actually, I am on PC and on Mac, right now on PC. Might be specific to PC though.

The whole thing is quite mysterious, as I tried various combinations, putting the mxf directly into the app dir and also into a sub dir of the app dir.

I also tried to open the mxf with the full version and the runtime, and I even distinguished between right click (open via context menu) vs. opening RT before and loading the mxf.

The only way how to reproduce the problem (but consistently) was to open the mxf via right click (context menu) with Runtime, in this case, it didn’t matter where the mxf was located. The predefined max-help path gave an error.

I attached the mxf I used, don’t worry about the loops folder down there. But I assume, you won’t be able to reproduce that on Mac.

Maybe somebody else could try:

1. Copy mxf to any dir
2. Right click and choose "Open With…"
3. Locate MaxRT.exe from your RT dir
4. Open

Now there should be a message in your max window like below:

folder: ./Cycling ’74/max-help: not a folder

Please confirm. Maybe there is a different init routine when using the context menu.

Viewing 3 posts - 1 through 3 (of 3 total)

Forums > MaxMSP