Forums > MaxMSP

gate~ without zero signal output on off outlets?


July 30, 2007 | 4:46 pm

I am routing an audio signal through a gate~ object configured to have multiple outputs. I want my patch to send the incoming audio out the ON gate~ outlet, but to NOT send zero’s out the other OFF outlets; rather, I just don’t want anything sent at all.

How can I do this??

Thanks,
Dan

July 30, 2007 | 4:55 pm

On 30 juil. 07, at 18:46, Dan Nigrin wrote:

> I am routing an audio signal through a gate~ object configured to
> have multiple outputs. I want my patch to send the incoming audio
> out the ON gate~ outlet, but to NOT send zero’s out the other OFF
> outlets; rather, I just don’t want anything sent at all.
>
> How can I do this??

This is not possible. In a signal connection there’s always signal
vectors going through. unless you stop the dac;)

ej

July 30, 2007 | 5:34 pm

Thanks Emmanuel.

After more work, I think I realize now that my problem is somewhere else in my patch anyway!!

Best,
Dan

July 31, 2007 | 12:03 am

I thought I would reply with what I found to be the bug in my patch, as this might help others in the future.

I have been routinely using send/receive even for audio signals these days, based on previous list discussions.

However, I’ve found a relatively simple way in which regular send/receive don’t work right with audio signals – you must use send~/receive~.

Please see attached patch. If you turn on the DAC, load up an audio file, start it playing, then try to switch the gate to 2 to let the signal pass, you won’t hear anything.

The only way to get the patch to work is to convert all send/receive to send~/receive~.

I’m sure this has to do with delaying the audio by one vector’s worth of audio or something like that that I don’t fully understand! Maybe someone can explain it…

Thanks,
Dan

#P window setfont "Sans Serif" 9.;
#P window linecount 1;
#P message 299 45 14 196617 2;
#P message 273 45 14 196617 1;
#P newex 280 101 55 196617 send to_A;
#P newex 324 45 68 196617 receive to_B;
#P newex 181 101 54 196617 send to_B;
#P newex 181 74 41 196617 *~ 1.;
#P newex 181 48 69 196617 receive to_A;
#P newex 46 104 55 196617 send to_A;
#P user ezdac~ 349 100 393 133 0;
#P newex 290 69 44 196617 gate~ 2;
#P message 46 48 31 196617 open;
#N sfplay~ 1 120960 0 ;
#P newobj 46 78 60 196617 sfplay~;
#P message 112 49 35 196617 loop 1;
#P toggle 85 48 15 0;
#P connect 0 0 2 0;
#P connect 1 0 2 0;
#P connect 3 0 2 0;
#P connect 2 0 6 0;
#P connect 7 0 8 0;
#P connect 8 0 9 0;
#P connect 4 0 11 0;
#P connect 12 0 4 0;
#P connect 13 0 4 0;
#P connect 10 0 4 1;
#P connect 4 1 5 0;
#P connect 4 1 5 1;
#P window clipboard copycount 14;

July 31, 2007 | 6:17 am

On 31 Jul 2007, at 01:03, Dan Nigrin wrote:

> Please see attached patch. If you turn on the DAC, load up an
> audio file, start it playing, then try to switch the gate to 2 to
> let the signal pass, you won’t hear anything.

My understanding may be a bit rusty, but my assumption was that the
non-twiddle send/receive connections were followed at DSP compilation
time, and couldn’t be altered dynamically.

— N.

nick rothwell — composition, systems, performance — http://
http://www.cassiel.com

July 31, 2007 | 8:26 am

July 31, 2007 | 11:52 am

Viewing 7 posts - 1 through 7 (of 7 total)

Forums > MaxMSP