Forums > Gen

Gen codebox crashing Max?


Nov 27 2015 | 10:48 pm

Max crashes when I command click on the top window bar of the codebox object. It has been happening a lot and I just figured out what has been causing it. Ugh.

Can anyone else reproduce this or is it something in my system?

— Pasted Max Patch, click to expand. —

slo
Nov 28 2015 | 12:19 pm

Same behaviour here. Yosemite 10.10.5, Max 7.0.6 32-bit or 64-bit.

Edited to add additional information.

Nov 28 2015 | 1:01 pm

Oh yeah.. Yosemite 10.10.5 here too. Max 7.0.1. I had a later increment installed and it was causing some other trouble so I went back to 7.0.1.

Sep 26 2016 | 2:30 pm

Hey, it has been almost a year and this problem still persists in Max 7.2.5. It wouldn’t be such an issue if crash recovery included the contents of [codebox].. but it doesn’t. Everything gets wiped. I use Sublime for most of my coding so I usually have some portion of the lost code, but Gen is all about real-time compiling and seeing results while coding within the patcher – so it’s easy to forget. Likewise cmd-click is how I lock and unlock backgrounds. It’s very easy to accidentally cmd-click the border of a [codebox] in edit mode.

I submitted a bug report when I first noticed the issue. Some sort of official response would be great. I have lost many hours of work. Truth be told, I will keep using Gen even if the problem doesn’t get fixed – and I will keep losing hours of work. But I’d rather not. Thanks for looking into it.

Viewing 4 posts - 1 through 4 (of 4 total)

Forums > Gen