Forums > Jitter

jit.grab problems in Max 6 on PC

Nov 03 2011 | 2:55 pm

I have been testing the jit.grab object in Max 6. I keep running into errors. Currently I am getting this error in Windows 7 x64 with a Logitech Pro C910 trying to use the jit.grab help file. (I also have installed (and uninstalled) many other tools to work with webcams in the past such as vdig 1.01, skype, google talk, and another one called webcamsplitter.)

0(NAME OF DEVICE HERE):Problem finding WinVDIG Video Renderer. Did you install as Admin?

I believe this object is supposed to work for both mac and pc by automatically choosing either a quicktime or directX grab. It seems like it is trying to use quicktime even though I am on a pc. Do you think that the new object still has bugs, or is there a problem with the software on my system? Thanks for your advice!

Nov 03 2011 | 3:24 pm

I’m by no means a pro (or even amature) but a couple things come to mind. On mac, I use jit.qt.grab; also have you tried connecting a "settings" message box to it and selecting a different source???

Sorry if I’m of no help!

Nov 03 2011 | 3:33 pm

Yeah jit.qt.grab seems to work great on my mac, but I really want to create patches that work cross platform. I have read in the forums that people figured out how to make a switch that knows if it is on a mac or pc and uses the correct grab object, but I was hoping this new grab object will have feature parity across both platforms.

Also, I don’t think you can use the settings message until a webcam is initialized, and the error message happens just before this.


Nov 03 2011 | 10:52 pm

Don’t forget that with a pc you have to type jit.dx.grab…

Nov 07 2011 | 10:23 pm

jit.grab is a new cross platform object in max 6, it is supposedly designed to correctly choose whether to use jit.dx.grab or jit.qt.grab. I am still trying to see if people are having luck using it. I still don’t have it working.

Nov 10 2011 | 4:50 pm

Had the same problem with the first version of 6, works fine now with 6.0.1 as far as I can tell

Aug 27 2015 | 7:53 pm

Just saw this post today; been using Max since 2012 or so, with a patch using jit.qt.grab.
I wondered why it wouldn’t work on a Win7 machine, then found this post.
jit.dx.grab works, as does jit.grab.
now both the built in web-cam on the laptop work, as does an IP EVO camera thru USB

Thank you all so much

  1. ssMax


Viewing 7 posts - 1 through 7 (of 7 total)

Forums > Jitter