Forums > Max For Live

jit.qt.grab can't open device

June 9, 2013 | 5:06 am

In a device I created and that worked yesterday, jit.qt.grab can’t access my mbp cam anymore. I get ‘could not create video channel -9405’ and ‘error opening device for grab’ messages. Grabbing worked with another device, and in max standalone. I restarted with no result.And suddenly as fast as it stopped working, it worked again. What does this error message mean ?

June 9, 2013 | 5:09 am

Funny, when trying to search google for that message, got this thread :
No one answered at that time so will I be more lucky ?

June 9, 2013 | 6:17 am

Hello Stephane

Are you using 64 or 32 bit Max? I noticed several problems with [jit.qt.grab] and [jit.grab] – especially related to stability (crashes or strange artefacts in image after on-the-fly resolution change), but never problem, like your. Anyway: I discover, that 64 bit Max is less stable (yet?) when I’ experimenting with grab.

Of course, I can look on your patch too, if you want to post something – maybe problem has different nature.

June 9, 2013 | 10:38 am

32 bit version. BTW, I think I found the reason but it’s still odd. Jit.qt.grab outputs to a texture and the receiving matrix didn’t receive any bang. So I changed my default metro setting. But should that prevent the cam to open ? I tried to make a patch with just an open message to jit.qt.grab and the cam opened so this makes me think this can’t be linked to the output of the object.

February 6, 2014 | 6:53 am

I’m still having a problem with this…I’m a bit of a newb but tried in both 64 bit and 32 bit max on a 64 bit machine…please help?

February 6, 2014 | 10:45 am

have you updated to 6.1.6?
which OS version?

March 7, 2014 | 1:55 pm

This problem is rearing its ugly head again…

I get the following error when I try to run jit.grab

jit.grab: jit.qt.grab: could not create video channel -9405
jit.grab: jit.qt.grab: error opening device for grab.

I am running on a Macbook Pro OSX 10.8.5, Max 6.1.6 (32-bit)

Any idea what the issue might be?

March 25, 2014 | 1:56 pm

Is there any word on this issue? I cant use my camera!

March 25, 2014 | 3:12 pm

if this is a newer laptop, it’s possible that the facetime camera won’t work with the older quicktime drivers.

in this case you need to tell jitter to use the newer drivers.
1. restart Max
2. new patcher
3. new message box with "; jit usealtgrab 1"
4. lock patcher and click message box

make sure you do this *before* you add any jitter objects to your patch.

if you find that your camera works with the new drivers, you can make this the default by typing "; jit usealtgrab 1" in a file named "jitter-config.txt", located anywhere in the search path and it will be executed when Jitter loads.

July 12, 2014 | 7:47 pm

Max 6.1.7 running in 32bits mode solved this for me [OS 10.9.4].

July 13, 2014 | 10:02 pm

I deal with this problem on my previous laptops.
[acer intel core 2 duo 2GHz, 4 GB RAM, Windows 7 OS – max 5.1.9]
[Fuzitsu intel i3 2.5GHz, 4 GB RAM, Windows 7 OS – max 6.1.3 – 32bit]
Ussaly I got this message when i closed the patcher without having previously closed the camera (with wclose message).
The only solution I had found was restarting max and sometimes OS.
Although with my new laptop [HP intel i7 2.2 GHz, 8GB RAM, Windows 8 OS max 6.1.7 32bit] this problem magically dissapeared even when i was running older max versions -eg max5 or max6.1.3 .
Please notice that this bug appeared also with external camera, so i am not sure that the only responsible is the driver.

  • This reply was modified 1 year by  tada.
  • This reply was modified 1 year by  tada.
  • This reply was modified 1 year by  tada.
September 12, 2014 | 8:56 pm

Since updating to Max 6.1.8 jit.grab no longer works for me. Running on Mac OS X version 10.6.8

February 25, 2015 | 7:34 am

Going to max preferences > all > jitter > video engine > avf
worked for me when i ran into the same problem on Max 7!

Viewing 13 posts - 1 through 13 (of 13 total)

Forums > Max For Live