Forums > Jitter

jit.qt.movie: Can find file ..


Aug 07 2010 | 1:24 pm

When trying to read and play a file, the Max window always tells me he cannot find the fie. The files are in the same folder as the patch however. What is wrong?

Attachments:
  1. forum.maxpat
Aug 07 2010 | 3:20 pm

Maybe you are not indicating the movie file extension, like e.g. "moviename.mov"? Also you should check the spaces in the name of the file like "my movie.mov", in this case you should indicate to jit.qt.movie the message [read "my movie.mov"], with quotes


efe
Aug 07 2010 | 3:35 pm

if you want to access directly a file you must search its path. You can do that by opening your terminal and dragging the file on it. Copy the path and place it after ‘read’. you will get something similar to this:
read /Users/blablabla/jitter_materials/images_impression/Van_Gogh_7.jpg
let us know if it works
-emmanuel

Aug 07 2010 | 4:38 pm

@ efe: Your solution works, however, this patch is part of an installation . I am making the patch here and will pass it on as a standalone to my client who does not have max. Is there another solution possible?


MIB
Aug 09 2010 | 9:35 pm

Here is something that I have used in the past. Drag the media folder onto the bpatcher and the contents will be loaded into the jit.cellblock. Click on the filename to play the movie/sound/pic….

Attachments:
  1. loadMedia.zip
Aug 09 2010 | 11:28 pm

When I drag a folder on top of it, I only get one cell, not various cells (the folder contains 3 films)


MIB
Aug 10 2010 | 12:08 am

Works fine here (MacBook Pro, OS 10.5.8). See if the "media" folder that comes with max works for you (I get 27 files loaded). Maybe I should also mention that right now only .mov files are accepted. If you have different file formats you need to change the "types" message sent to the [folder] object.

Hope that helps.

Aug 10 2010 | 12:12 am

Ok, It worked, I had some other types. This time I only used mov

Aug 22 2010 | 4:39 pm

@MIB: I was wondering if I could use mpeg4 files; They are smaller in filesize so I would prfer using them. I just have to load a message that says mp4 right?

Aug 23 2010 | 4:34 pm

to use mpeg4, you will have to edit max-fileformats.txt to add mp4.
can be something like:
max fileformat .mp4 MP4 0 Video moviefile;


MIB
Aug 24 2010 | 3:09 am

what robtherich said I guess :)
never actually tried that before…

Aug 24 2010 | 8:19 am

Can you tell me where to find the max-fileformats.txt. Spotlight cannot find it.

Aug 24 2010 | 3:46 pm

/Applications/Max5/Cycling ’74/init/max-fileformats.txt

Aug 24 2010 | 5:06 pm

I changed the fileformats.txt but when I choose mp4 i only get an aiff file named D in the list.

Viewing 14 posts - 1 through 14 (of 14 total)

Forums > Jitter