Forums > MaxMSP

Max 5 crashes on startup w/ malloc error

Sep 19 2012 | 9:56 pm

Hi there,

I’m having a funny problem with Max all of a sudden. It hangs every time I launch it. It shows a spinning wheel mouse cursor and it’s totally unresponsive until I "force quit". It doesn’t display any error messages, but the following shows up in my console log:

>12-09-19 5:38:46.344 PM [0x0-0x4c04c].com.cycling74.MaxMSP: MaxMSP(978,0xad1632c0) malloc: *** error for object 0x4fa1000: pointer being freed was not allocated
>12-09-19 5:38:46.344 PM [0x0-0x4c04c].com.cycling74.MaxMSP: *** set a breakpoint in malloc_error_break to debug

I’ve tried deleting ~/Library/Preferences/Max 5 Preferences/. I’ve also tried reinstalling Max. No dice.

I’m on a mac, running os 10.7.4.

Does anyone have any idea what’s going on and how to fix it?

Many thanks,


Sep 19 2012 | 10:11 pm

That error is unrelated to your non-startup.

Perhaps your MIDI or audio drivers are not starting correctly? Try moving them out of the midi driver and ad folders in your Cycling ’74 folder


Sep 19 2012 | 10:25 pm

Thanks for the response. Hm… so I’ve emptied ad/ and mididrivers/. Now I get an error saying that there’s "no mididriver folder or default driver" AND it hangs. :s

Hrmph. Any others ideas?

Sep 19 2012 | 10:39 pm

ok, put that stuff back then.

Send in all your details to support@ and we’ll try and figure out what might have changed on your computer.


Sep 19 2012 | 10:52 pm

Ok, done. Thanks again for your help.

Sep 19 2012 | 11:25 pm

The helpful people @support showed me the way. It turns out that I just needed to manually delete the /Applications/Max5/ folder before reinstalling. Now everything’s working perfectly. :)

Viewing 6 posts - 1 through 6 (of 6 total)

Forums > MaxMSP