Forums > MaxMSP

max user interface questions


Jan 18 2013 | 11:00 pm

hi,
just wondering about two small issues, very simple but it’s driving me nuts and i could not find an answer to these:

– does andyone know wether it is possible to deactivate the max keyboard shortcuts? i use an external controller which is programmed via keystrokes and which always generates buttons, number fields etc. when using while the patch is in edit mode – since max uses the same keys… especially since they even do the same with shift (like "shift + b" generates a button just as with "b")…

– another detail quite annoying too: is there any way to max start the way you close it? like same window size, with the pane to the right expanded and set to "max"? it is only three clicks but still annoying every time anew…

thanks in advance and all the best
karl

Jan 18 2013 | 11:36 pm

1) don’t perform in edit mode. lock it up, and no problems. is there a specific reason you are in edit mode while performing?

2) just save the file as big and wherever you want it, and it will open that way

Jan 19 2013 | 11:04 am

hey, thanks for your quick reply!
about 1): well, i need to run it while developing it… sure, ideally i would then lock the patch but it’s just not how it works. in the end i have to options: a) every couple of hours go over my patch and search for randomly generated objects (which is what i used to do a lot) or b) using a keyboard setup avoiding the max shortcuts – which i do now but makes my patch completely unusuable if i do not have the controller with me plus i am running out of keys.

regarding the windows: the size might be saved but the max window will always be hidden and if i open it, it will always show the explorer first…

Jan 19 2013 | 11:58 am

What kind of controller is it? It’s generally not great to go with keypresses as controls, for reasons you’re experiencing, but also if max is not the ‘focus’, the keypresses won’t work either.

You can also try compartmentalizing your patch so you only end up creating objects where you can easily find/delete them (last resort).

So it’s the max window you need? Or your patch window? or both?

Pretty sure the max window saves position too. Opening your patch may open it ‘on top’ of the max window, but if you save your patch off to the side, it should be fine, I would think.

Jan 19 2013 | 10:09 pm

it’s a simple contour shuttlexpress… and actually, the keypresses/shuttlecontrols do work – they just generate lots of objects simultaneously…
anyway, if there is no easy way to fix this i guess i can live with it… it’s just somewhat annoying…
anyway, thanks a lot for your help!
best
k

Jan 20 2013 | 2:02 am

I’m not really following this:

> well, i need to run it while developing it… sure, ideally i would then lock the patch but it’s just not how it works. in the end i have to options: a) every couple of hours go over my patch and search for randomly generated objects

You mean if you exit edit mode for those "couple of hours" it won’t work? Or is there another problem with exiting edit mode?
i ask because I can’t recall a single time where I had to work in edit mode, if I wasn’t editing.

Jan 20 2013 | 8:25 am

Hi.

To disable Max’s keyboard shortcuts, remove the "max-keycommands.txt" (and any other third-party keycommands file you might have, such as bach-keycommands, ftm-keycommands, etc.) from your Cycling ’74/init folder, and restart Max.

hth
aa

Viewing 7 posts - 1 through 7 (of 7 total)

Forums > MaxMSP