Forums > MaxMSP

Max6 – coords disappearing over panel ?

Feb 08 2012 | 12:08 pm


I just got Max 6 and found an odd behaviour that wasn’t present in the last version.

When I lock a patch the patch coords that are running over a panel object disappear… Is there a preference that I missed ? I have tried the obvious such as sending the panel object to the back but no luck.

-- Pasted Max Patch, click to expand. --

Feb 08 2012 | 12:31 pm

didn’t check your patch but there was a thread not long ago. i think -it will work if you include the panel in the background(object inspector)- was the answer.

Feb 08 2012 | 3:43 pm

yeah the "problem" is for the most part a good thing, that cables now pop under objects when the patch is locked. Sometimes you want different behaviour.

Feb 08 2012 | 7:18 pm

Thanks 11olsen, I didn’t see that thread ! I think it’s an odd behaviour since there is an option to hide the patch coords and there is the presentation mode as well. It’s odd because the send to back function doesn’t change anything either ! Since the focus on version 6 was usability, it’s definitely a usability bug !

I use the panel to highlight a part of the patch for tutorials that I do for my students and there is now quite some work to be done now !

Feb 08 2012 | 7:51 pm

It’s mostly a good feature, but I agree that it’s an irritation in your particular use case. The "universal" object might make your life a little easier.

Drop this in your patch and click on the message box:

-- Pasted Max Patch, click to expand. --

Feb 08 2012 | 8:29 pm

Nice one, thanks mzed !

Viewing 6 posts - 1 through 6 (of 6 total)

Forums > MaxMSP