Forums > Jitter

More than one line with

Jul 28 2008 | 5:17 pm

Hi all,
I have a simple question, but i need to ask.
I’m displaying text using [] and I’m calling files from a folder using the object [text]. The text files are just comments that somebody previously type using [textedit].
By problem is that i can’t find the way to show the text in more that one line. How can I control the numbers of lines that [] displays? i know that it could be really simple, but I missing this step.
Thanks for the help

Jul 28 2008 | 8:17 pm

You might want to take a look at jit.textfile and jit.fprint. Regardless, you will want to make sure that you are saving your carriage returns. With textedit, you will want to be sure you are either appending carriage returns or outputting the contents as one symbol (output mode attribute set to 1).

If you are still having trouble, post a simple patch.


Jul 28 2008 | 9:57 pm

I was trying to have more lines using jit.textfile but I don’t get it.
Here is part of the patch, I just trying to put the text into the output window. When I have long text I don’t find the way to organize it in a column.
Thanks for all


— Pasted Max Patch, click to expand. —

[MOD – reposted with copy compressed]

Jul 29 2008 | 12:10 am

For posting patches, check out ‘copy compressed’ in the Edit menu. Try something like this:

— Pasted Max Patch, click to expand. —
Jul 29 2008 | 6:58 am

Hi Ben,

It’s perfect for me this example.
Thanks a lot for the help!

Jul 29 2008 | 7:01 am

Hi Ben,
It’s perfect the example, this is what I’m searching for.
Thanks a lot for the help!

Aug 15 2009 | 6:23 am

It’s pretty weird…
I can not open the max 5 Patch:

clipboard JSON conversion
‘,’ or ‘}’ character expected after value for key ‘linecount’: line=182, char=24, text=’…his isnseveralnlinesnof jitterntext", "linecount" : 5 {‘


Aug 17 2009 | 9:08 am

May someone attach the Ben’s max 5 patch ?
I’ve upgraded my soft but it still doesn’t work.



Aug 17 2009 | 5:00 pm

can you try this version?
i’ve cleared the text object, which i think might’ve caused you the problems.

also, can you post your system info?

— Pasted Max Patch, click to expand. —

Aug 17 2009 | 6:15 pm

It Does work !!!
Thanks a lot !!


Oct 12 2010 | 3:43 pm

It is regular: text2d needs to receive first a "text somewords" before the matrix works as expected?

-- Pasted Max Patch, click to expand. --

Oct 13 2010 | 12:13 pm

I insist, what is the issue with [].
For example the Recipe 19: Tannenbaum :
It does not work until you send a "text" message to text2d.

MBP 2.93GHZ 4Go 1067MHz DDR3 9400M+9600MGT
MaxMSPJitter 5.1.5

Oct 13 2010 | 4:45 pm

Works with Max4, no satisfying results with Max5. What am missing?

Oct 13 2010 | 5:31 pm

Hi Kyred,

Thanks for pointing this out. Its either a bug or a doc error, I’ll figure out which.


Oct 13 2010 | 6:59 pm

This should be fixed for the next update, thanks!


Oct 13 2010 | 7:53 pm

i was having the same issue with Recipe 28

Oct 13 2010 | 7:59 pm

is there any temporal solution for this problem when using multiple lines of text?, at least until the next update!

Oct 13 2010 | 8:04 pm

Not sure what you mean. You should be able to use multiple lines of text, just send any ‘text’ message before sending it matrix data.

But maybe I don’t understand your problem. Post a patch?


Feb 01 2011 | 7:51 pm

can I render a to the same instance of jit.pwindow ?

still looking for another way to display subtitles parsed from my srt files.

the main target: using more than one subtitle at a time (one on each line)

Nov 14 2015 | 4:21 pm

[delete this please]

Nov 14 2015 | 4:24 pm

[delete this please]

Nov 14 2015 | 4:31 pm

I built a real-time typing visualiser with multiple lines feature, based on Rob’s patch.
You have a weird behaviour when you ‘delete’ a ‘space’ or a letter, and when you hit ‘return’ after a ‘space’.
I could not find a solution unfortunately.

-- Pasted Max Patch, click to expand. --

Nov 14 2015 | 5:06 pm

With the previous patch, I tried to make Jitter Tutorial 29 (Using The Alpha Channel) OpenGL-based.
However I failed because writes solid letters upon my alpha-blended letters. Is there any way to avoid that?
Thanks a lot,

-- Pasted Max Patch, click to expand. --

Nov 15 2015 | 12:31 am

are the colors mapped as rgba instead of argb when they are in a texture ?
also, when i connect the output of the under the to a jit.pwindow, it’s all black, no sign of letters. Is that normal ?

Nov 16 2015 | 12:01 pm

hi masa, check my post here for a possible fix for your first problem:

for your second problem, you must use (with @erase_color 0 0 0 0) to capture the text and create the alpha mask:

-- Pasted Max Patch, click to expand. --

Viewing 25 posts - 1 through 25 (of 25 total)

Forums > Jitter