Forums > MaxMSP

odd buffer~ problem

Jun 03 2010 | 6:58 pm

so i’ve got this patch (max 4.6 on osx 10.4.11) where i’m using buffer & waveform to crop audio files. no big deal, right out of the help file. what’s different is that i’m using sfinfo~ at the same time to give me bit channels/depth/sample rate info. then i’m using the file name out of sfinfo~ and [prepend replace] into the buffer~ to change audio files. on some audio files this works fine, on others i get an error message that says buffer~ can’t open file. if i use [replace] directly into the buffer~ that file loads. if i try to send the message [replace audiofile], i get the error. any idea what i’m doing wrong? or what might be up with some of my audio files?


Jun 03 2010 | 9:42 pm

It might be because the [replace] message allows you to manually load a file, without Max first knowing where it is; however, if Max doesn’t see these folders at startup, it is unaware of their existence, so you should add the required folder(s) in File Preferences. Ooooh, you’re using 4.x, I don’t know where the File/Folder Preferences dialog lives, but have a look in Max’s Options or Settings or wherever. This MAY solve it.

Jun 05 2010 | 2:42 am

interesting thought. does that mean if i record a new file with sfrecord~, i’ll have to shut down & reload max so it sees the file? hmmm. i’ll go test . . . Thanks!


May 04 2011 | 10:34 pm

I was using the MAX example sounds as placeholders in subfolders and it was working fine with the replace message to buffer~. When I began adding my own samples I was confused because buffer~ couldn’t read them.

Adding the desired folders to the Max 5 File Preferences search path solved this problem for me.

However, after doing so, when I opened that same patch in Runtime, buffer~ was unable to open the samples in my subfolders.

I would like to use subfolders to keep my different collections of samples tidy, instead of loading them all into the same level folder as the maxpatch. I would also like this patch to work in Max 5 Runtime.

Is it too much to ask, I wonder? :}

Here’s the section of my patch which tells the buffer~ which file to replace (the outlet goes directly into the top, left inleft of the buffer~ object)

-- Pasted Max Patch, click to expand. --

What’s wacky, in my opinion, is that the umenu object has always been able to list the samples in the subfolder indicated; File Preference search path adjustments or not.

Hmmm haaa…

Does MAX 5 save the File Preferences search path list along with the patch?


Is there anyway to have the buffer~ object read files from subfolders without having to add them to the File Preferences list?

Viewing 4 posts - 1 through 4 (of 4 total)

Forums > MaxMSP