Forums > MaxMSP

sfrecord~ err -1 – can't make file

June 20, 2012 | 12:00 pm

Hi all,
I’m trying to make a patch where a file with the name "ghost%i.aif" is created and recorded into an sfrecord~ object where %i is a random integer.

I’m using sprintf to format the message as described in the sprintf help file.

I can make the files apparently (?) as their zero-kb placeholders are appearing, correctly formatted, into the correct filepath.

But I get this error message in the Max window:

"can’t make file Macintosh:/Users/Jason/Documents/Computer Music projects and components/Sounding Circle/SCGhosts/ghost%i.aif, err -1."

— Pasted Max Patch, click to expand. —

What gives??? The open dialog works just fine.

June 20, 2012 | 5:21 pm

Are you sure that you not accidently trying to open more then one filename at once, or change the filename after sending sfrecord an open message but not actually recorded anything perhaps? These are the only ways I’ve been able to replicate your problem. When I just open your patch, choose a filename, record a sample, and then repeat it works grand…

similar topic here

…. alternatively you could use record~ and buffer~ as suggested here

June 20, 2012 | 9:24 pm

Interestingly, a restart of Max 6 solved the problem (should always be the first step I guess). But it was weird that the same problem was happening in Max 5 when I tried opening the patch in there too.

I’ll keep an eye on changes and update if any other problems come up…thanks for the reply, chubby!


June 21, 2012 | 10:06 am

No bothers man!

Viewing 4 posts - 1 through 4 (of 4 total)

Forums > MaxMSP