Forums > MaxMSP

Slice This!

Jan 09 2009 | 3:56 am

Hey all,
( I tried to post this a few days ago but I never saw it post on the forum.
Please forgive me if this is a duplicate post)

Here is my first attempt at making a beat slicers. I would really love to
have some of you Master Patchers show me some better ways of thinking about
what I have made. Keep in mind that you must have a sample that splits in
half nicely. It also helps if you have a sample that is 16 step. If there is
a better way to go about this please share, I am sure there are others on
here who would love to know. I noticed that there is something similar to
this in the example patches but i decided to try and reason my way through
the whole thing. At this point i will try and dig into that thing. I would
love for everyone interested to pimp the heck outa this thing and have it be
a learning experience for all.

Possible functionality to add: Stretch sample to match master tempo? Silence
clipping? Sync to midi scrub? Other ideas? Make it a VST?

Have at it :)


Right click and save :)

Jan 09 2009 | 5:25 am

i like it!

Jan 09 2009 | 8:38 am

This is something for any of you who don’t have samples. It works nicely.

On Thu, Jan 8, 2009 at 9:25 PM, Blake Shaw wrote:

> i like it!
> —
> "There’s no need to fear or hope, but only to look for new weapons." –
> Giles Deleuze

Jan 09 2009 | 9:01 am

I’m getting an ‘Internal Server Error blah, blah…’
Any chance you could just post this as an attachment, or better still, inline text…?

Jan 09 2009 | 8:55 pm

— Pasted Max Patch, click to expand. —
Jan 09 2009 | 10:45 pm

Edit – Copy Compressed

Jan 10 2009 | 12:08 am

yeah, sorry, i noticed that after i posted it but was to late to edit… thanks!

Jan 10 2009 | 11:24 am

I’m attempting to build an App version of a patch to run on another
Mac. I’ve solved most of the issues except for the following – I keep
getting these error messages when I run the App…

Jitter 1.7.0 installed unable to find CG framework.
jit.openexr: No such object jit.openexr not found, openexr support unavailable

According to the documentation, building an app containing should automatically copy Cg.framework into the app.
I’ve had a look inside the app folder, and the Cg.framework folder
_isn’t there.

I tried copying the framework across, putting it in the Frameworks
folder. But I still get the error message.

Also, the docs say copy the jitter-shaders folder to /Contents/MacOS/
support/ , but /MacOS and /support are 2 folders at the same level –
so I put the shaders folder into /support, which I hope is correct.

Any ideas on how I can get this working? Either fixing Max so that the
Cg.framework is properly copied across, or how to do it manually so
that at least I can get the app working.I need to get this working by
Monday afternoon, so any pointers are much appreciated!

(I can’t use a standalone as there are quite a few in the
patch, and (AFAIK) you can’t copy externals into a standalone. And isn’t installed on the target machine)



Jan 10 2009 | 12:15 pm

Ok this has got to work :) sorry about all that, i really hope you guys dig in and tear this thing apart :)

Jan 10 2009 | 12:52 pm

Does anyone know if MaxScore works in Max 5 yet?



Jan 10 2009 | 1:27 pm

Went ahead and installed it and answered my own question – the answer
being, yes, it appears to work.

On 10 Jan 2009, at 12:52, David Stevens wrote:

> Does anyone know if MaxScore works in Max 5 yet?
> thanks
> David

Mar 09 2009 | 3:57 am


I am just starting with Max 5. I was just wondering how you got MaxScore to work with 5? Did you simply change the installation folder to Max 5.0? I did this and then get a "No such object" error, when I write "maxscore" in a new object box. :/

Is there something I’m missing?


Mar 09 2009 | 4:15 am

Smile cool stuff. Perhaps look into multislider for sequencing? (your sequencer seems a bit lacking. Multislider allows really quick, on the fly, editing of sequences. Perfect for a beat slicer).

Viewing 13 posts - 1 through 13 (of 13 total)

Forums > MaxMSP