Forums > Jitter

specular matrix for mesh – "invalid input type" meassage

Feb 13 2014 | 5:24 am

I’m trying to draw particle system with gl.mesh object.
I send vertex matrix to mesh first inlet and get my 500 cubes.
Then I send color matrix (float32, 4 planes, same dim as vertex matrix) and get my cubes colored.
but I have to set mesh attribute lighting_enable to 0, in order to see the color.
and then my cubes don’t react to light – they dont have shadows.
I’ trying to send specular matrix to mesh’ 5th inlet, but get message " invalid input type" in max window.
I’ve been trying float32 and char, 3 or 4 planes, but still get this message.
I found somewhere in forum, that this specular matrix should have same dim as vertex matrix, but from where comes this "invalid input type"?

draw_mode is "quads", I tried auto_normals, auto_tangents, sending normal matrix, still the same problem.

Any help, or pointing out to search will be appreciated.

* I’m doing the stuff with max5 for some reasons (had some problems to move to max6, even though I do have it)
thanks, Sakerdon

here is example patch, which draws 1 quad for simplicity.
I’m getting "invalid input type", when setting matrix "spe" to val 1 (step 5)

-- Pasted Max Patch, click to expand. --


Feb 23 2014 | 12:22 pm

looks to be a bug.
thanks for the report.

Oct 05 2014 | 2:50 pm

any results / updates on this bug?

I can’t attach anything to the specular array input without throwing "invalid input type" errors

Viewing 3 posts - 1 through 3 (of 3 total)

Forums > Jitter